Nexus 2.7 Can not Login After Fresh Installation

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Nexus 2.7 Can not Login After Fresh Installation

Can Cömert
This post has NOT been accepted by the mailing list yet.
Hi,

I have installed nexus on a Debian machine.
It starts without any problem, I dont se any exceptions on the log files but;
I can not login neither with admin/admin123 nor with anonymous user.

Here is my security.xml
<?xml version="1.0" encoding="UTF-8"?>
<security>
  <version>2.0.5</version>
  <users>
    <user>
      <id>admin</id>
      <firstName>Administrator</firstName>
      <lastName>User</lastName>
      <password>f865b53623b121fd34ee5426c792e5c33af8c227</password>
      <status>active</status>
      [hidden email]
    </user>
    <user>
      <id>deployment</id>
      <firstName>Deployment</firstName>
      <lastName>User</lastName>
      <password>b2a0e378437817cebdf753d7dff3dd75483af9e0</password>
      <status>active</status>
      [hidden email]
    </user>
    <user>
      <id>anonymous</id>
      <firstName>Nexus</firstName>
      <lastName>Anonymous User</lastName>
      <password>$shiro1$SHA-512$1024$y+b2W8vyYSNaPB8rqChC3g==$Wxqth+kTI30UcWTQoSiRDyoIlSuQAk1xHlMZBbsvNYJdszfTPSIija50xR2ARkTtKdzjjDIJc1W7lf1FWcXQmw==</password>
      <status>active</status>
      [hidden email]
    </user>
  </users>
  <userRoleMappings>
    <userRoleMapping>
      <userId>admin</userId>
      <source>default</source>
      <roles>
        <role>nx-admin</role>
      </roles>
    </userRoleMapping>
...

Here is my security-configuration.xml
<?xml version="1.0"?>
<security-configuration>
  <version>2.0.7</version>
  <anonymousAccessEnabled>true</anonymousAccessEnabled>
  <anonymousUsername>anonymous</anonymousUsername>
  <anonymousPassword>{T5Lv5YWowZ0HPg5J14MdoqWCJ2TWukxrzbvXvuwoUbw=}</anonymousPassword>
  <realms>
    <realm>XmlAuthenticatingRealm</realm>
    <realm>XmlAuthorizingRealm</realm>
  </realms>
  <hashIterations>1024</hashIterations>
</security-configuration>


Here is the end of log output:
jvm 1    | 2014-03-18 22:55:13 INFO  [jetty-main-thread-1]  org.sonatype.nexus.bootstrap.jetty.InstrumentedSelectChannelConnector - Metrics enabled
jvm 1    | 2014-03-18 22:55:13 INFO  [jetty-main-thread-1]  org.eclipse.jetty.server.AbstractConnector - Started InstrumentedSelectChannelConnector@0.0.0.0:8090
jvm 1    | 2014-03-18 22:59:34 INFO  [qtp1334045764-36] *UNKNOWN /nexus - nexus: [Noelios Restlet Engine] - Attaching application: org.sonatype.nexus.rest.NexusApplication@3adaa157 to URI: /nexus
jvm 1    | 2014-03-18 22:59:40 INFO  [qtp1334045764-37]  org.apache.shiro.nexus5727.FixedDefaultWebSessionManager - Global session timeout: 1800000 ms
jvm 1    | 2014-03-18 22:59:40 INFO  [qtp1334045764-37]  org.apache.shiro.session.mgt.AbstractValidatingSessionManager - Enabling session validation scheduler...
jvm 1    | 2014-03-18 22:59:40 INFO  [qtp1334045764-34]  org.sonatype.security.model.source.FileModelConfigurationSource - Loading security configuration from: /usr/local/nexus-2.7.2-03/../sonatype-work/nexus/conf/security.xml
jvm 1    | 2014-03-18 22:59:43 INFO  [qtp1334045764-34]  org.sonatype.nexus.security.filter.authc.NexusAuthenticationFilter - Unable to authenticate user [anonymous] from IP Address 127.0.0.1
jvm 1    | 2014-03-18 22:59:51 INFO  [qtp1334045764-35]  org.sonatype.nexus.security.filter.authc.NexusAuthenticationFilter - Unable to authenticate user [anonymous] from IP Address 127.0.0.1


Can anyone help me??