Modernizing plugin dependencies

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Modernizing plugin dependencies

Benson Margulies
What's current best practice for updating the versions of the test harness
and other bits and bobs?
Reply | Threaded
Open this post in threaded view
|

Re: Modernizing plugin dependencies

Elliotte Rusty Harold
It's a very good thing to do. That said, updating the test harness is
usually a lot more difficult than it looks. It tends to pull in
incompatible versions of Plexus, Sisu, and Aether requiring a lot of
code changes throughout the plugin.


On Tue, May 12, 2020 at 8:00 PM Benson Margulies <[hidden email]> wrote:
>
> What's current best practice for updating the versions of the test harness
> and other bits and bobs?



--
Elliotte Rusty Harold
[hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]