Maven enforcer plugin failing with maven 3.6.1 but passing with maven 3.6.3

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Maven enforcer plugin failing with maven 3.6.1 but passing with maven 3.6.3

Debraj Manna
Hi

In one of my project I am trying to use DependencyConvergence rule with
maven enforcer plugin. I am observing that if I use maven 3.6.1 then the
enforcer is failing with the below error but the same has been working fine
with maven 3.6.3. Can someone let me know if this expected? If yes can
someone point me to the relevant jira under which this issue is fixed in
maven 3.6.3.

I have placed a sample project in https://github.com/debraj-manna/es-plugins
where this issue can be reproduced.

maven-enforcer-plugin - 3.0.0-M2

Debrajs-MacBook-Air:es-plugins debrajmanna$
~/Downloads/apache-maven-3.6.1/bin/mvn validate
[INFO] Scanning for projects...
[INFO]
------------------------------------------------------------------------
[INFO] Reactor Build Order:
[INFO]
[INFO] es-plugins
[pom]
[INFO] dedup
 [jar]
[INFO]
[INFO] -----------------------< org.example:es-plugins
>-----------------------
[INFO] Building es-plugins 1.0-SNAPSHOT
[1/2]
[INFO] --------------------------------[ pom
]---------------------------------
[INFO]
[INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
(javaversion-dependencyconvergence) @ es-plugins ---
[INFO]
[INFO] -------------------------< org.example:dedup
>--------------------------
[INFO] Building dedup 1.0-SNAPSHOT
 [2/2]
[INFO] --------------------------------[ jar
]---------------------------------
[INFO]
[INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
(javaversion-dependencyconvergence) @ dedup ---
[WARNING]
Dependency convergence error for
com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1 paths to
dependency are:
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.apache.lucene:lucene-test-framework:8.5.1
      +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.2

[WARNING]
Dependency convergence error for commons-logging:commons-logging:1.2 paths
to dependency are:
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
      +-org.apache.httpcomponents:httpclient:4.5.10
        +-commons-logging:commons-logging:1.2
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
      +-org.apache.httpcomponents:httpasyncclient:4.1.4
        +-commons-logging:commons-logging:1.2
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
      +-commons-logging:commons-logging:1.1.3
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
      +-commons-logging:commons-logging:1.1.3
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-commons-logging:commons-logging:1.1.3

[WARNING]
Dependency convergence error for org.apache.httpcomponents:httpcore:4.4.12
paths to dependency are:
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
      +-org.apache.httpcomponents:httpclient:4.5.10
        +-org.apache.httpcomponents:httpcore:4.4.12
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
      +-org.apache.httpcomponents:httpcore:4.4.12
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
      +-org.apache.httpcomponents:httpasyncclient:4.1.4
        +-org.apache.httpcomponents:httpcore:4.4.10
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
      +-org.apache.httpcomponents:httpcore:4.4.12

[WARNING]
Dependency convergence error for
org.apache.httpcomponents:httpclient:4.5.10 paths to dependency are:
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
      +-org.apache.httpcomponents:httpclient:4.5.10
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
      +-org.apache.httpcomponents:httpasyncclient:4.1.4
        +-org.apache.httpcomponents:httpclient:4.5.6
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
      +-org.apache.httpcomponents:httpclient:4.5.10

[WARNING]
Dependency convergence error for
org.apache.httpcomponents:httpcore-nio:4.4.10 paths to dependency are:
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
      +-org.apache.httpcomponents:httpasyncclient:4.1.4
        +-org.apache.httpcomponents:httpcore-nio:4.4.10
and
+-org.example:dedup:1.0-SNAPSHOT
  +-org.elasticsearch.test:framework:7.7.1
    +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
      +-org.apache.httpcomponents:httpcore-nio:4.4.12

[WARNING] Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence
failed with message:
Failed while enforcing releasability. See above detailed error message.
[INFO]
------------------------------------------------------------------------
[INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
[INFO]
[INFO] es-plugins ......................................... SUCCESS [
 3.047 s]
[INFO] dedup .............................................. FAILURE [
 0.856 s]
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time:  4.131 s
[INFO] Finished at: 2020-08-29T11:41:55+05:30
[INFO]
------------------------------------------------------------------------
[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M2:enforce
(javaversion-dependencyconvergence) on project dedup: Some Enforcer rules
have failed. Look above for specific messages explaining why the rule
failed. -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the
command
[ERROR]   mvn <goals> -rf :dedup
Debrajs-MacBook-Air:es-plugins debrajmanna$
~/Downloads/apache-maven-3.6.3/bin/mvn validate
[INFO] Scanning for projects...
[INFO]
------------------------------------------------------------------------
[INFO] Reactor Build Order:
[INFO]
[INFO] es-plugins
[pom]
[INFO] dedup
 [jar]
[INFO]
[INFO] -----------------------< org.example:es-plugins
>-----------------------
[INFO] Building es-plugins 1.0-SNAPSHOT
[1/2]
[INFO] --------------------------------[ pom
]---------------------------------
[INFO]
[INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
(javaversion-dependencyconvergence) @ es-plugins ---
[INFO]
[INFO] -------------------------< org.example:dedup
>--------------------------
[INFO] Building dedup 1.0-SNAPSHOT
 [2/2]
[INFO] --------------------------------[ jar
]---------------------------------
[INFO]
[INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
(javaversion-dependencyconvergence) @ dedup ---
[INFO]
------------------------------------------------------------------------
[INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
[INFO]
[INFO] es-plugins ......................................... SUCCESS [
 1.743 s]
[INFO] dedup .............................................. SUCCESS [
 0.510 s]
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO]
------------------------------------------------------------------------
[INFO] Total time:  2.462 s
[INFO] Finished at: 2020-08-29T11:42:06+05:30
[INFO]
------------------------------------------------------------------------

Same is working fine in maven 3.6.3.

Debrajs-MacBook-Air:es-plugins debrajmanna$
~/Downloads/apache-maven-3.6.3/bin/mvn validate
[INFO] Scanning for projects...
[INFO]
------------------------------------------------------------------------
[INFO] Reactor Build Order:
[INFO]
[INFO] es-plugins
[pom]
[INFO] dedup
 [jar]
[INFO]
[INFO] -----------------------< org.example:es-plugins
>-----------------------
[INFO] Building es-plugins 1.0-SNAPSHOT
[1/2]
[INFO] --------------------------------[ pom
]---------------------------------
[INFO]
[INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
(javaversion-dependencyconvergence) @ es-plugins ---
[INFO]
[INFO] -------------------------< org.example:dedup
>--------------------------
[INFO] Building dedup 1.0-SNAPSHOT
 [2/2]
[INFO] --------------------------------[ jar
]---------------------------------
[INFO]
[INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
(javaversion-dependencyconvergence) @ dedup ---
[INFO]
------------------------------------------------------------------------
[INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
[INFO]
[INFO] es-plugins ......................................... SUCCESS [
 1.743 s]
[INFO] dedup .............................................. SUCCESS [
 0.510 s]
[INFO]
------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO]
------------------------------------------------------------------------
[INFO] Total time:  2.462 s
[INFO] Finished at: 2020-08-29T11:42:06+05:30
[INFO]
------------------------------------------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: Maven enforcer plugin failing with maven 3.6.1 but passing with maven 3.6.3

Debraj Manna
Just to be more explicit with maven versions. I tried with maven version
3.6.1, 3.6.3 and 3.5.3. It worked fine only with 3.6.3.

On Sat, Aug 29, 2020 at 12:04 PM Debraj Manna <[hidden email]>
wrote:

> Hi
>
> In one of my project I am trying to use DependencyConvergence rule with
> maven enforcer plugin. I am observing that if I use maven 3.6.1 then the
> enforcer is failing with the below error but the same has been working fine
> with maven 3.6.3. Can someone let me know if this expected? If yes can
> someone point me to the relevant jira under which this issue is fixed in
> maven 3.6.3.
>
> I have placed a sample project in
> https://github.com/debraj-manna/es-plugins where this issue can be
> reproduced.
>
> maven-enforcer-plugin - 3.0.0-M2
>
> Debrajs-MacBook-Air:es-plugins debrajmanna$
> ~/Downloads/apache-maven-3.6.1/bin/mvn validate
> [INFO] Scanning for projects...
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Build Order:
> [INFO]
> [INFO] es-plugins
> [pom]
> [INFO] dedup
>  [jar]
> [INFO]
> [INFO] -----------------------< org.example:es-plugins
> >-----------------------
> [INFO] Building es-plugins 1.0-SNAPSHOT
> [1/2]
> [INFO] --------------------------------[ pom
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ es-plugins ---
> [INFO]
> [INFO] -------------------------< org.example:dedup
> >--------------------------
> [INFO] Building dedup 1.0-SNAPSHOT
>  [2/2]
> [INFO] --------------------------------[ jar
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ dedup ---
> [WARNING]
> Dependency convergence error for
> com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1 paths to
> dependency are:
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.apache.lucene:lucene-test-framework:8.5.1
>       +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.2
>
> [WARNING]
> Dependency convergence error for commons-logging:commons-logging:1.2 paths
> to dependency are:
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>       +-org.apache.httpcomponents:httpclient:4.5.10
>         +-commons-logging:commons-logging:1.2
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>       +-org.apache.httpcomponents:httpasyncclient:4.1.4
>         +-commons-logging:commons-logging:1.2
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>       +-commons-logging:commons-logging:1.1.3
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>       +-commons-logging:commons-logging:1.1.3
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-commons-logging:commons-logging:1.1.3
>
> [WARNING]
> Dependency convergence error for org.apache.httpcomponents:httpcore:4.4.12
> paths to dependency are:
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>       +-org.apache.httpcomponents:httpclient:4.5.10
>         +-org.apache.httpcomponents:httpcore:4.4.12
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>       +-org.apache.httpcomponents:httpcore:4.4.12
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>       +-org.apache.httpcomponents:httpasyncclient:4.1.4
>         +-org.apache.httpcomponents:httpcore:4.4.10
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>       +-org.apache.httpcomponents:httpcore:4.4.12
>
> [WARNING]
> Dependency convergence error for
> org.apache.httpcomponents:httpclient:4.5.10 paths to dependency are:
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>       +-org.apache.httpcomponents:httpclient:4.5.10
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>       +-org.apache.httpcomponents:httpasyncclient:4.1.4
>         +-org.apache.httpcomponents:httpclient:4.5.6
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>       +-org.apache.httpcomponents:httpclient:4.5.10
>
> [WARNING]
> Dependency convergence error for
> org.apache.httpcomponents:httpcore-nio:4.4.10 paths to dependency are:
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>       +-org.apache.httpcomponents:httpasyncclient:4.1.4
>         +-org.apache.httpcomponents:httpcore-nio:4.4.10
> and
> +-org.example:dedup:1.0-SNAPSHOT
>   +-org.elasticsearch.test:framework:7.7.1
>     +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>       +-org.apache.httpcomponents:httpcore-nio:4.4.12
>
> [WARNING] Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence
> failed with message:
> Failed while enforcing releasability. See above detailed error message.
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
> [INFO]
> [INFO] es-plugins ......................................... SUCCESS [
>  3.047 s]
> [INFO] dedup .............................................. FAILURE [
>  0.856 s]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time:  4.131 s
> [INFO] Finished at: 2020-08-29T11:41:55+05:30
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) on project dedup: Some Enforcer rules
> have failed. Look above for specific messages explaining why the rule
> failed. -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> [ERROR]
> [ERROR] After correcting the problems, you can resume the build with the
> command
> [ERROR]   mvn <goals> -rf :dedup
> Debrajs-MacBook-Air:es-plugins debrajmanna$
> ~/Downloads/apache-maven-3.6.3/bin/mvn validate
> [INFO] Scanning for projects...
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Build Order:
> [INFO]
> [INFO] es-plugins
> [pom]
> [INFO] dedup
>  [jar]
> [INFO]
> [INFO] -----------------------< org.example:es-plugins
> >-----------------------
> [INFO] Building es-plugins 1.0-SNAPSHOT
> [1/2]
> [INFO] --------------------------------[ pom
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ es-plugins ---
> [INFO]
> [INFO] -------------------------< org.example:dedup
> >--------------------------
> [INFO] Building dedup 1.0-SNAPSHOT
>  [2/2]
> [INFO] --------------------------------[ jar
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ dedup ---
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
> [INFO]
> [INFO] es-plugins ......................................... SUCCESS [
>  1.743 s]
> [INFO] dedup .............................................. SUCCESS [
>  0.510 s]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESS
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time:  2.462 s
> [INFO] Finished at: 2020-08-29T11:42:06+05:30
> [INFO]
> ------------------------------------------------------------------------
>
> Same is working fine in maven 3.6.3.
>
> Debrajs-MacBook-Air:es-plugins debrajmanna$
> ~/Downloads/apache-maven-3.6.3/bin/mvn validate
> [INFO] Scanning for projects...
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Build Order:
> [INFO]
> [INFO] es-plugins
> [pom]
> [INFO] dedup
>  [jar]
> [INFO]
> [INFO] -----------------------< org.example:es-plugins
> >-----------------------
> [INFO] Building es-plugins 1.0-SNAPSHOT
> [1/2]
> [INFO] --------------------------------[ pom
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ es-plugins ---
> [INFO]
> [INFO] -------------------------< org.example:dedup
> >--------------------------
> [INFO] Building dedup 1.0-SNAPSHOT
>  [2/2]
> [INFO] --------------------------------[ jar
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ dedup ---
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
> [INFO]
> [INFO] es-plugins ......................................... SUCCESS [
>  1.743 s]
> [INFO] dedup .............................................. SUCCESS [
>  0.510 s]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESS
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time:  2.462 s
> [INFO] Finished at: 2020-08-29T11:42:06+05:30
> [INFO]
> ------------------------------------------------------------------------
>
Reply | Threaded
Open this post in threaded view
|

Re: Maven enforcer plugin failing with maven 3.6.1 but passing with maven 3.6.3

Karl Heinz Marbaise-3
In reply to this post by Debraj Manna
Hi,

as already mentioned on SO the behaviour can't be reproduced with the
example project.

Tested with Maven 3.6.0, 3.6.1, 3.6.2 and 3.6.3...

Kind regards
Karl Heinz Marbaise
On 29.08.20 08:34, Debraj Manna wrote:

> Hi
>
> In one of my project I am trying to use DependencyConvergence rule with
> maven enforcer plugin. I am observing that if I use maven 3.6.1 then the
> enforcer is failing with the below error but the same has been working fine
> with maven 3.6.3. Can someone let me know if this expected? If yes can
> someone point me to the relevant jira under which this issue is fixed in
> maven 3.6.3.
>
> I have placed a sample project in https://github.com/debraj-manna/es-plugins
> where this issue can be reproduced.
>
> maven-enforcer-plugin - 3.0.0-M2
>
> Debrajs-MacBook-Air:es-plugins debrajmanna$
> ~/Downloads/apache-maven-3.6.1/bin/mvn validate
> [INFO] Scanning for projects...
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Build Order:
> [INFO]
> [INFO] es-plugins
> [pom]
> [INFO] dedup
>   [jar]
> [INFO]
> [INFO] -----------------------< org.example:es-plugins
>> -----------------------
> [INFO] Building es-plugins 1.0-SNAPSHOT
> [1/2]
> [INFO] --------------------------------[ pom
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ es-plugins ---
> [INFO]
> [INFO] -------------------------< org.example:dedup
>> --------------------------
> [INFO] Building dedup 1.0-SNAPSHOT
>   [2/2]
> [INFO] --------------------------------[ jar
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ dedup ---
> [WARNING]
> Dependency convergence error for
> com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1 paths to
> dependency are:
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.apache.lucene:lucene-test-framework:8.5.1
>        +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.2
>
> [WARNING]
> Dependency convergence error for commons-logging:commons-logging:1.2 paths
> to dependency are:
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>        +-org.apache.httpcomponents:httpclient:4.5.10
>          +-commons-logging:commons-logging:1.2
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>          +-commons-logging:commons-logging:1.2
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>        +-commons-logging:commons-logging:1.1.3
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>        +-commons-logging:commons-logging:1.1.3
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-commons-logging:commons-logging:1.1.3
>
> [WARNING]
> Dependency convergence error for org.apache.httpcomponents:httpcore:4.4.12
> paths to dependency are:
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>        +-org.apache.httpcomponents:httpclient:4.5.10
>          +-org.apache.httpcomponents:httpcore:4.4.12
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>        +-org.apache.httpcomponents:httpcore:4.4.12
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>          +-org.apache.httpcomponents:httpcore:4.4.10
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>        +-org.apache.httpcomponents:httpcore:4.4.12
>
> [WARNING]
> Dependency convergence error for
> org.apache.httpcomponents:httpclient:4.5.10 paths to dependency are:
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>        +-org.apache.httpcomponents:httpclient:4.5.10
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>          +-org.apache.httpcomponents:httpclient:4.5.6
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>        +-org.apache.httpcomponents:httpclient:4.5.10
>
> [WARNING]
> Dependency convergence error for
> org.apache.httpcomponents:httpcore-nio:4.4.10 paths to dependency are:
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>          +-org.apache.httpcomponents:httpcore-nio:4.4.10
> and
> +-org.example:dedup:1.0-SNAPSHOT
>    +-org.elasticsearch.test:framework:7.7.1
>      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>        +-org.apache.httpcomponents:httpcore-nio:4.4.12
>
> [WARNING] Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence
> failed with message:
> Failed while enforcing releasability. See above detailed error message.
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
> [INFO]
> [INFO] es-plugins ......................................... SUCCESS [
>   3.047 s]
> [INFO] dedup .............................................. FAILURE [
>   0.856 s]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time:  4.131 s
> [INFO] Finished at: 2020-08-29T11:41:55+05:30
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) on project dedup: Some Enforcer rules
> have failed. Look above for specific messages explaining why the rule
> failed. -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e
> switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> [ERROR]
> [ERROR] After correcting the problems, you can resume the build with the
> command
> [ERROR]   mvn <goals> -rf :dedup
> Debrajs-MacBook-Air:es-plugins debrajmanna$
> ~/Downloads/apache-maven-3.6.3/bin/mvn validate
> [INFO] Scanning for projects...
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Build Order:
> [INFO]
> [INFO] es-plugins
> [pom]
> [INFO] dedup
>   [jar]
> [INFO]
> [INFO] -----------------------< org.example:es-plugins
>> -----------------------
> [INFO] Building es-plugins 1.0-SNAPSHOT
> [1/2]
> [INFO] --------------------------------[ pom
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ es-plugins ---
> [INFO]
> [INFO] -------------------------< org.example:dedup
>> --------------------------
> [INFO] Building dedup 1.0-SNAPSHOT
>   [2/2]
> [INFO] --------------------------------[ jar
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ dedup ---
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
> [INFO]
> [INFO] es-plugins ......................................... SUCCESS [
>   1.743 s]
> [INFO] dedup .............................................. SUCCESS [
>   0.510 s]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESS
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time:  2.462 s
> [INFO] Finished at: 2020-08-29T11:42:06+05:30
> [INFO]
> ------------------------------------------------------------------------
>
> Same is working fine in maven 3.6.3.
>
> Debrajs-MacBook-Air:es-plugins debrajmanna$
> ~/Downloads/apache-maven-3.6.3/bin/mvn validate
> [INFO] Scanning for projects...
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Build Order:
> [INFO]
> [INFO] es-plugins
> [pom]
> [INFO] dedup
>   [jar]
> [INFO]
> [INFO] -----------------------< org.example:es-plugins
>> -----------------------
> [INFO] Building es-plugins 1.0-SNAPSHOT
> [1/2]
> [INFO] --------------------------------[ pom
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ es-plugins ---
> [INFO]
> [INFO] -------------------------< org.example:dedup
>> --------------------------
> [INFO] Building dedup 1.0-SNAPSHOT
>   [2/2]
> [INFO] --------------------------------[ jar
> ]---------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> (javaversion-dependencyconvergence) @ dedup ---
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
> [INFO]
> [INFO] es-plugins ......................................... SUCCESS [
>   1.743 s]
> [INFO] dedup .............................................. SUCCESS [
>   0.510 s]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESS
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time:  2.462 s
> [INFO] Finished at: 2020-08-29T11:42:06+05:30
> [INFO]
> ------------------------------------------------------------------------
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Maven enforcer plugin failing with maven 3.6.1 but passing with maven 3.6.3

Debraj Manna
It is failing consistently in our environment. Can you let me know what can
cause this difference in behavior?

Any other log I can provide that may help in debugging this issue further?

On Sat, Aug 29, 2020 at 4:45 PM Karl Heinz Marbaise <[hidden email]>
wrote:

> Hi,
>
> as already mentioned on SO the behaviour can't be reproduced with the
> example project.
>
> Tested with Maven 3.6.0, 3.6.1, 3.6.2 and 3.6.3...
>
> Kind regards
> Karl Heinz Marbaise
> On 29.08.20 08:34, Debraj Manna wrote:
> > Hi
> >
> > In one of my project I am trying to use DependencyConvergence rule with
> > maven enforcer plugin. I am observing that if I use maven 3.6.1 then the
> > enforcer is failing with the below error but the same has been working
> fine
> > with maven 3.6.3. Can someone let me know if this expected? If yes can
> > someone point me to the relevant jira under which this issue is fixed in
> > maven 3.6.3.
> >
> > I have placed a sample project in
> https://github.com/debraj-manna/es-plugins
> > where this issue can be reproduced.
> >
> > maven-enforcer-plugin - 3.0.0-M2
> >
> > Debrajs-MacBook-Air:es-plugins debrajmanna$
> > ~/Downloads/apache-maven-3.6.1/bin/mvn validate
> > [INFO] Scanning for projects...
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Reactor Build Order:
> > [INFO]
> > [INFO] es-plugins
> > [pom]
> > [INFO] dedup
> >   [jar]
> > [INFO]
> > [INFO] -----------------------< org.example:es-plugins
> >> -----------------------
> > [INFO] Building es-plugins 1.0-SNAPSHOT
> > [1/2]
> > [INFO] --------------------------------[ pom
> > ]---------------------------------
> > [INFO]
> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> > (javaversion-dependencyconvergence) @ es-plugins ---
> > [INFO]
> > [INFO] -------------------------< org.example:dedup
> >> --------------------------
> > [INFO] Building dedup 1.0-SNAPSHOT
> >   [2/2]
> > [INFO] --------------------------------[ jar
> > ]---------------------------------
> > [INFO]
> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> > (javaversion-dependencyconvergence) @ dedup ---
> > [WARNING]
> > Dependency convergence error for
> > com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1 paths
> to
> > dependency are:
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.apache.lucene:lucene-test-framework:8.5.1
> >
> +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.2
> >
> > [WARNING]
> > Dependency convergence error for commons-logging:commons-logging:1.2
> paths
> > to dependency are:
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
> >        +-org.apache.httpcomponents:httpclient:4.5.10
> >          +-commons-logging:commons-logging:1.2
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
> >          +-commons-logging:commons-logging:1.2
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
> >        +-commons-logging:commons-logging:1.1.3
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
> >        +-commons-logging:commons-logging:1.1.3
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-commons-logging:commons-logging:1.1.3
> >
> > [WARNING]
> > Dependency convergence error for
> org.apache.httpcomponents:httpcore:4.4.12
> > paths to dependency are:
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
> >        +-org.apache.httpcomponents:httpclient:4.5.10
> >          +-org.apache.httpcomponents:httpcore:4.4.12
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
> >        +-org.apache.httpcomponents:httpcore:4.4.12
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
> >          +-org.apache.httpcomponents:httpcore:4.4.10
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
> >        +-org.apache.httpcomponents:httpcore:4.4.12
> >
> > [WARNING]
> > Dependency convergence error for
> > org.apache.httpcomponents:httpclient:4.5.10 paths to dependency are:
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
> >        +-org.apache.httpcomponents:httpclient:4.5.10
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
> >          +-org.apache.httpcomponents:httpclient:4.5.6
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
> >        +-org.apache.httpcomponents:httpclient:4.5.10
> >
> > [WARNING]
> > Dependency convergence error for
> > org.apache.httpcomponents:httpcore-nio:4.4.10 paths to dependency are:
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
> >          +-org.apache.httpcomponents:httpcore-nio:4.4.10
> > and
> > +-org.example:dedup:1.0-SNAPSHOT
> >    +-org.elasticsearch.test:framework:7.7.1
> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
> >        +-org.apache.httpcomponents:httpcore-nio:4.4.12
> >
> > [WARNING] Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence
> > failed with message:
> > Failed while enforcing releasability. See above detailed error message.
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
> > [INFO]
> > [INFO] es-plugins ......................................... SUCCESS [
> >   3.047 s]
> > [INFO] dedup .............................................. FAILURE [
> >   0.856 s]
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] BUILD FAILURE
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Total time:  4.131 s
> > [INFO] Finished at: 2020-08-29T11:41:55+05:30
> > [INFO]
> > ------------------------------------------------------------------------
> > [ERROR] Failed to execute goal
> > org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M2:enforce
> > (javaversion-dependencyconvergence) on project dedup: Some Enforcer rules
> > have failed. Look above for specific messages explaining why the rule
> > failed. -> [Help 1]
> > [ERROR]
> > [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e
> > switch.
> > [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> > [ERROR]
> > [ERROR] For more information about the errors and possible solutions,
> > please read the following articles:
> > [ERROR] [Help 1]
> > http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> > [ERROR]
> > [ERROR] After correcting the problems, you can resume the build with the
> > command
> > [ERROR]   mvn <goals> -rf :dedup
> > Debrajs-MacBook-Air:es-plugins debrajmanna$
> > ~/Downloads/apache-maven-3.6.3/bin/mvn validate
> > [INFO] Scanning for projects...
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Reactor Build Order:
> > [INFO]
> > [INFO] es-plugins
> > [pom]
> > [INFO] dedup
> >   [jar]
> > [INFO]
> > [INFO] -----------------------< org.example:es-plugins
> >> -----------------------
> > [INFO] Building es-plugins 1.0-SNAPSHOT
> > [1/2]
> > [INFO] --------------------------------[ pom
> > ]---------------------------------
> > [INFO]
> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> > (javaversion-dependencyconvergence) @ es-plugins ---
> > [INFO]
> > [INFO] -------------------------< org.example:dedup
> >> --------------------------
> > [INFO] Building dedup 1.0-SNAPSHOT
> >   [2/2]
> > [INFO] --------------------------------[ jar
> > ]---------------------------------
> > [INFO]
> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> > (javaversion-dependencyconvergence) @ dedup ---
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
> > [INFO]
> > [INFO] es-plugins ......................................... SUCCESS [
> >   1.743 s]
> > [INFO] dedup .............................................. SUCCESS [
> >   0.510 s]
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] BUILD SUCCESS
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Total time:  2.462 s
> > [INFO] Finished at: 2020-08-29T11:42:06+05:30
> > [INFO]
> > ------------------------------------------------------------------------
> >
> > Same is working fine in maven 3.6.3.
> >
> > Debrajs-MacBook-Air:es-plugins debrajmanna$
> > ~/Downloads/apache-maven-3.6.3/bin/mvn validate
> > [INFO] Scanning for projects...
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Reactor Build Order:
> > [INFO]
> > [INFO] es-plugins
> > [pom]
> > [INFO] dedup
> >   [jar]
> > [INFO]
> > [INFO] -----------------------< org.example:es-plugins
> >> -----------------------
> > [INFO] Building es-plugins 1.0-SNAPSHOT
> > [1/2]
> > [INFO] --------------------------------[ pom
> > ]---------------------------------
> > [INFO]
> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> > (javaversion-dependencyconvergence) @ es-plugins ---
> > [INFO]
> > [INFO] -------------------------< org.example:dedup
> >> --------------------------
> > [INFO] Building dedup 1.0-SNAPSHOT
> >   [2/2]
> > [INFO] --------------------------------[ jar
> > ]---------------------------------
> > [INFO]
> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
> > (javaversion-dependencyconvergence) @ dedup ---
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
> > [INFO]
> > [INFO] es-plugins ......................................... SUCCESS [
> >   1.743 s]
> > [INFO] dedup .............................................. SUCCESS [
> >   0.510 s]
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] BUILD SUCCESS
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Total time:  2.462 s
> > [INFO] Finished at: 2020-08-29T11:42:06+05:30
> > [INFO]
> > ------------------------------------------------------------------------
> >
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Maven enforcer plugin failing with maven 3.6.1 but passing with maven 3.6.3

Debraj Manna
I am observing the same behavior with maven docker also. It is passing with
3.6.3 but failing with 3.6.1.

Used the below commands

Debrajs-MacBook-Air:es-plugins debrajmanna$ docker run -it --rm --name
es-plugins -v "$(pwd)":/Users/debrajmanna/code/vnera/es-plugins -w
/Users/debrajmanna/code/vnera/es-plugins maven:3.6.1 mvn validate

Debrajs-MacBook-Air:es-plugins debrajmanna$ docker run -it --rm --name
es-plugins -v "$(pwd)":/Users/debrajmanna/code/vnera/es-plugins -w
/Users/debrajmanna/code/vnera/es-plugins maven:3.6.3 mvn validate

On Sat, Aug 29, 2020 at 5:32 PM Debraj Manna <[hidden email]>
wrote:

> It is failing consistently in our environment. Can you let me know what
> can cause this difference in behavior?
>
> Any other log I can provide that may help in debugging this issue further?
>
> On Sat, Aug 29, 2020 at 4:45 PM Karl Heinz Marbaise <[hidden email]>
> wrote:
>
>> Hi,
>>
>> as already mentioned on SO the behaviour can't be reproduced with the
>> example project.
>>
>> Tested with Maven 3.6.0, 3.6.1, 3.6.2 and 3.6.3...
>>
>> Kind regards
>> Karl Heinz Marbaise
>> On 29.08.20 08:34, Debraj Manna wrote:
>> > Hi
>> >
>> > In one of my project I am trying to use DependencyConvergence rule with
>> > maven enforcer plugin. I am observing that if I use maven 3.6.1 then the
>> > enforcer is failing with the below error but the same has been working
>> fine
>> > with maven 3.6.3. Can someone let me know if this expected? If yes can
>> > someone point me to the relevant jira under which this issue is fixed in
>> > maven 3.6.3.
>> >
>> > I have placed a sample project in
>> https://github.com/debraj-manna/es-plugins
>> > where this issue can be reproduced.
>> >
>> > maven-enforcer-plugin - 3.0.0-M2
>> >
>> > Debrajs-MacBook-Air:es-plugins debrajmanna$
>> > ~/Downloads/apache-maven-3.6.1/bin/mvn validate
>> > [INFO] Scanning for projects...
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] Reactor Build Order:
>> > [INFO]
>> > [INFO] es-plugins
>> > [pom]
>> > [INFO] dedup
>> >   [jar]
>> > [INFO]
>> > [INFO] -----------------------< org.example:es-plugins
>> >> -----------------------
>> > [INFO] Building es-plugins 1.0-SNAPSHOT
>> > [1/2]
>> > [INFO] --------------------------------[ pom
>> > ]---------------------------------
>> > [INFO]
>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>> > (javaversion-dependencyconvergence) @ es-plugins ---
>> > [INFO]
>> > [INFO] -------------------------< org.example:dedup
>> >> --------------------------
>> > [INFO] Building dedup 1.0-SNAPSHOT
>> >   [2/2]
>> > [INFO] --------------------------------[ jar
>> > ]---------------------------------
>> > [INFO]
>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>> > (javaversion-dependencyconvergence) @ dedup ---
>> > [WARNING]
>> > Dependency convergence error for
>> > com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1 paths
>> to
>> > dependency are:
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.apache.lucene:lucene-test-framework:8.5.1
>> >
>> +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.2
>> >
>> > [WARNING]
>> > Dependency convergence error for commons-logging:commons-logging:1.2
>> paths
>> > to dependency are:
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>> >        +-org.apache.httpcomponents:httpclient:4.5.10
>> >          +-commons-logging:commons-logging:1.2
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>> >          +-commons-logging:commons-logging:1.2
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>> >        +-commons-logging:commons-logging:1.1.3
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>> >        +-commons-logging:commons-logging:1.1.3
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-commons-logging:commons-logging:1.1.3
>> >
>> > [WARNING]
>> > Dependency convergence error for
>> org.apache.httpcomponents:httpcore:4.4.12
>> > paths to dependency are:
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>> >        +-org.apache.httpcomponents:httpclient:4.5.10
>> >          +-org.apache.httpcomponents:httpcore:4.4.12
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>> >        +-org.apache.httpcomponents:httpcore:4.4.12
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>> >          +-org.apache.httpcomponents:httpcore:4.4.10
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>> >        +-org.apache.httpcomponents:httpcore:4.4.12
>> >
>> > [WARNING]
>> > Dependency convergence error for
>> > org.apache.httpcomponents:httpclient:4.5.10 paths to dependency are:
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>> >        +-org.apache.httpcomponents:httpclient:4.5.10
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>> >          +-org.apache.httpcomponents:httpclient:4.5.6
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>> >        +-org.apache.httpcomponents:httpclient:4.5.10
>> >
>> > [WARNING]
>> > Dependency convergence error for
>> > org.apache.httpcomponents:httpcore-nio:4.4.10 paths to dependency are:
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>> >          +-org.apache.httpcomponents:httpcore-nio:4.4.10
>> > and
>> > +-org.example:dedup:1.0-SNAPSHOT
>> >    +-org.elasticsearch.test:framework:7.7.1
>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>> >        +-org.apache.httpcomponents:httpcore-nio:4.4.12
>> >
>> > [WARNING] Rule 0:
>> org.apache.maven.plugins.enforcer.DependencyConvergence
>> > failed with message:
>> > Failed while enforcing releasability. See above detailed error message.
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
>> > [INFO]
>> > [INFO] es-plugins ......................................... SUCCESS [
>> >   3.047 s]
>> > [INFO] dedup .............................................. FAILURE [
>> >   0.856 s]
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] BUILD FAILURE
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] Total time:  4.131 s
>> > [INFO] Finished at: 2020-08-29T11:41:55+05:30
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [ERROR] Failed to execute goal
>> > org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M2:enforce
>> > (javaversion-dependencyconvergence) on project dedup: Some Enforcer
>> rules
>> > have failed. Look above for specific messages explaining why the rule
>> > failed. -> [Help 1]
>> > [ERROR]
>> > [ERROR] To see the full stack trace of the errors, re-run Maven with
>> the -e
>> > switch.
>> > [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> > [ERROR]
>> > [ERROR] For more information about the errors and possible solutions,
>> > please read the following articles:
>> > [ERROR] [Help 1]
>> > http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
>> > [ERROR]
>> > [ERROR] After correcting the problems, you can resume the build with the
>> > command
>> > [ERROR]   mvn <goals> -rf :dedup
>> > Debrajs-MacBook-Air:es-plugins debrajmanna$
>> > ~/Downloads/apache-maven-3.6.3/bin/mvn validate
>> > [INFO] Scanning for projects...
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] Reactor Build Order:
>> > [INFO]
>> > [INFO] es-plugins
>> > [pom]
>> > [INFO] dedup
>> >   [jar]
>> > [INFO]
>> > [INFO] -----------------------< org.example:es-plugins
>> >> -----------------------
>> > [INFO] Building es-plugins 1.0-SNAPSHOT
>> > [1/2]
>> > [INFO] --------------------------------[ pom
>> > ]---------------------------------
>> > [INFO]
>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>> > (javaversion-dependencyconvergence) @ es-plugins ---
>> > [INFO]
>> > [INFO] -------------------------< org.example:dedup
>> >> --------------------------
>> > [INFO] Building dedup 1.0-SNAPSHOT
>> >   [2/2]
>> > [INFO] --------------------------------[ jar
>> > ]---------------------------------
>> > [INFO]
>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>> > (javaversion-dependencyconvergence) @ dedup ---
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
>> > [INFO]
>> > [INFO] es-plugins ......................................... SUCCESS [
>> >   1.743 s]
>> > [INFO] dedup .............................................. SUCCESS [
>> >   0.510 s]
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] BUILD SUCCESS
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] Total time:  2.462 s
>> > [INFO] Finished at: 2020-08-29T11:42:06+05:30
>> > [INFO]
>> > ------------------------------------------------------------------------
>> >
>> > Same is working fine in maven 3.6.3.
>> >
>> > Debrajs-MacBook-Air:es-plugins debrajmanna$
>> > ~/Downloads/apache-maven-3.6.3/bin/mvn validate
>> > [INFO] Scanning for projects...
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] Reactor Build Order:
>> > [INFO]
>> > [INFO] es-plugins
>> > [pom]
>> > [INFO] dedup
>> >   [jar]
>> > [INFO]
>> > [INFO] -----------------------< org.example:es-plugins
>> >> -----------------------
>> > [INFO] Building es-plugins 1.0-SNAPSHOT
>> > [1/2]
>> > [INFO] --------------------------------[ pom
>> > ]---------------------------------
>> > [INFO]
>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>> > (javaversion-dependencyconvergence) @ es-plugins ---
>> > [INFO]
>> > [INFO] -------------------------< org.example:dedup
>> >> --------------------------
>> > [INFO] Building dedup 1.0-SNAPSHOT
>> >   [2/2]
>> > [INFO] --------------------------------[ jar
>> > ]---------------------------------
>> > [INFO]
>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>> > (javaversion-dependencyconvergence) @ dedup ---
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
>> > [INFO]
>> > [INFO] es-plugins ......................................... SUCCESS [
>> >   1.743 s]
>> > [INFO] dedup .............................................. SUCCESS [
>> >   0.510 s]
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] BUILD SUCCESS
>> > [INFO]
>> > ------------------------------------------------------------------------
>> > [INFO] Total time:  2.462 s
>> > [INFO] Finished at: 2020-08-29T11:42:06+05:30
>> > [INFO]
>> > ------------------------------------------------------------------------
>> >
>>
>>
Reply | Threaded
Open this post in threaded view
|

Re: Maven enforcer plugin failing with maven 3.6.1 but passing with maven 3.6.3

Debraj Manna
This has been answered in stackoverflow
<https://stackoverflow.com/questions/63644201/why-is-maven-enforcer-plugin-failing-with-maven-version-3-6-1-but-passing-with-3>


https://stackoverflow.com/questions/63644201/why-is-maven-enforcer-plugin-failing-with-maven-version-3-6-1-but-passing-with-3

On Sat, Aug 29, 2020 at 6:37 PM Debraj Manna <[hidden email]>
wrote:

> I am observing the same behavior with maven docker also. It is passing
> with 3.6.3 but failing with 3.6.1.
>
> Used the below commands
>
> Debrajs-MacBook-Air:es-plugins debrajmanna$ docker run -it --rm --name
> es-plugins -v "$(pwd)":/Users/debrajmanna/code/vnera/es-plugins -w
> /Users/debrajmanna/code/vnera/es-plugins maven:3.6.1 mvn validate
>
> Debrajs-MacBook-Air:es-plugins debrajmanna$ docker run -it --rm --name
> es-plugins -v "$(pwd)":/Users/debrajmanna/code/vnera/es-plugins -w
> /Users/debrajmanna/code/vnera/es-plugins maven:3.6.3 mvn validate
>
> On Sat, Aug 29, 2020 at 5:32 PM Debraj Manna <[hidden email]>
> wrote:
>
>> It is failing consistently in our environment. Can you let me know what
>> can cause this difference in behavior?
>>
>> Any other log I can provide that may help in debugging this issue further?
>>
>> On Sat, Aug 29, 2020 at 4:45 PM Karl Heinz Marbaise <[hidden email]>
>> wrote:
>>
>>> Hi,
>>>
>>> as already mentioned on SO the behaviour can't be reproduced with the
>>> example project.
>>>
>>> Tested with Maven 3.6.0, 3.6.1, 3.6.2 and 3.6.3...
>>>
>>> Kind regards
>>> Karl Heinz Marbaise
>>> On 29.08.20 08:34, Debraj Manna wrote:
>>> > Hi
>>> >
>>> > In one of my project I am trying to use DependencyConvergence rule with
>>> > maven enforcer plugin. I am observing that if I use maven 3.6.1 then
>>> the
>>> > enforcer is failing with the below error but the same has been working
>>> fine
>>> > with maven 3.6.3. Can someone let me know if this expected? If yes can
>>> > someone point me to the relevant jira under which this issue is fixed
>>> in
>>> > maven 3.6.3.
>>> >
>>> > I have placed a sample project in
>>> https://github.com/debraj-manna/es-plugins
>>> > where this issue can be reproduced.
>>> >
>>> > maven-enforcer-plugin - 3.0.0-M2
>>> >
>>> > Debrajs-MacBook-Air:es-plugins debrajmanna$
>>> > ~/Downloads/apache-maven-3.6.1/bin/mvn validate
>>> > [INFO] Scanning for projects...
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] Reactor Build Order:
>>> > [INFO]
>>> > [INFO] es-plugins
>>> > [pom]
>>> > [INFO] dedup
>>> >   [jar]
>>> > [INFO]
>>> > [INFO] -----------------------< org.example:es-plugins
>>> >> -----------------------
>>> > [INFO] Building es-plugins 1.0-SNAPSHOT
>>> > [1/2]
>>> > [INFO] --------------------------------[ pom
>>> > ]---------------------------------
>>> > [INFO]
>>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>>> > (javaversion-dependencyconvergence) @ es-plugins ---
>>> > [INFO]
>>> > [INFO] -------------------------< org.example:dedup
>>> >> --------------------------
>>> > [INFO] Building dedup 1.0-SNAPSHOT
>>> >   [2/2]
>>> > [INFO] --------------------------------[ jar
>>> > ]---------------------------------
>>> > [INFO]
>>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>>> > (javaversion-dependencyconvergence) @ dedup ---
>>> > [WARNING]
>>> > Dependency convergence error for
>>> > com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1
>>> paths to
>>> > dependency are:
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >
>>> +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.1
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.apache.lucene:lucene-test-framework:8.5.1
>>> >
>>> +-com.carrotsearch.randomizedtesting:randomizedtesting-runner:2.7.2
>>> >
>>> > [WARNING]
>>> > Dependency convergence error for commons-logging:commons-logging:1.2
>>> paths
>>> > to dependency are:
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>>> >        +-org.apache.httpcomponents:httpclient:4.5.10
>>> >          +-commons-logging:commons-logging:1.2
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>>> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>>> >          +-commons-logging:commons-logging:1.2
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>>> >        +-commons-logging:commons-logging:1.1.3
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>>> >        +-commons-logging:commons-logging:1.1.3
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-commons-logging:commons-logging:1.1.3
>>> >
>>> > [WARNING]
>>> > Dependency convergence error for
>>> org.apache.httpcomponents:httpcore:4.4.12
>>> > paths to dependency are:
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>>> >        +-org.apache.httpcomponents:httpclient:4.5.10
>>> >          +-org.apache.httpcomponents:httpcore:4.4.12
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>>> >        +-org.apache.httpcomponents:httpcore:4.4.12
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>>> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>>> >          +-org.apache.httpcomponents:httpcore:4.4.10
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>>> >        +-org.apache.httpcomponents:httpcore:4.4.12
>>> >
>>> > [WARNING]
>>> > Dependency convergence error for
>>> > org.apache.httpcomponents:httpclient:4.5.10 paths to dependency are:
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>>> >        +-org.apache.httpcomponents:httpclient:4.5.10
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>>> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>>> >          +-org.apache.httpcomponents:httpclient:4.5.6
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client-sniffer:7.7.1
>>> >        +-org.apache.httpcomponents:httpclient:4.5.10
>>> >
>>> > [WARNING]
>>> > Dependency convergence error for
>>> > org.apache.httpcomponents:httpcore-nio:4.4.10 paths to dependency are:
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>>> >        +-org.apache.httpcomponents:httpasyncclient:4.1.4
>>> >          +-org.apache.httpcomponents:httpcore-nio:4.4.10
>>> > and
>>> > +-org.example:dedup:1.0-SNAPSHOT
>>> >    +-org.elasticsearch.test:framework:7.7.1
>>> >      +-org.elasticsearch.client:elasticsearch-rest-client:7.7.1
>>> >        +-org.apache.httpcomponents:httpcore-nio:4.4.12
>>> >
>>> > [WARNING] Rule 0:
>>> org.apache.maven.plugins.enforcer.DependencyConvergence
>>> > failed with message:
>>> > Failed while enforcing releasability. See above detailed error message.
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
>>> > [INFO]
>>> > [INFO] es-plugins ......................................... SUCCESS [
>>> >   3.047 s]
>>> > [INFO] dedup .............................................. FAILURE [
>>> >   0.856 s]
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] BUILD FAILURE
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] Total time:  4.131 s
>>> > [INFO] Finished at: 2020-08-29T11:41:55+05:30
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [ERROR] Failed to execute goal
>>> > org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M2:enforce
>>> > (javaversion-dependencyconvergence) on project dedup: Some Enforcer
>>> rules
>>> > have failed. Look above for specific messages explaining why the rule
>>> > failed. -> [Help 1]
>>> > [ERROR]
>>> > [ERROR] To see the full stack trace of the errors, re-run Maven with
>>> the -e
>>> > switch.
>>> > [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>>> > [ERROR]
>>> > [ERROR] For more information about the errors and possible solutions,
>>> > please read the following articles:
>>> > [ERROR] [Help 1]
>>> >
>>> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
>>> > [ERROR]
>>> > [ERROR] After correcting the problems, you can resume the build with
>>> the
>>> > command
>>> > [ERROR]   mvn <goals> -rf :dedup
>>> > Debrajs-MacBook-Air:es-plugins debrajmanna$
>>> > ~/Downloads/apache-maven-3.6.3/bin/mvn validate
>>> > [INFO] Scanning for projects...
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] Reactor Build Order:
>>> > [INFO]
>>> > [INFO] es-plugins
>>> > [pom]
>>> > [INFO] dedup
>>> >   [jar]
>>> > [INFO]
>>> > [INFO] -----------------------< org.example:es-plugins
>>> >> -----------------------
>>> > [INFO] Building es-plugins 1.0-SNAPSHOT
>>> > [1/2]
>>> > [INFO] --------------------------------[ pom
>>> > ]---------------------------------
>>> > [INFO]
>>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>>> > (javaversion-dependencyconvergence) @ es-plugins ---
>>> > [INFO]
>>> > [INFO] -------------------------< org.example:dedup
>>> >> --------------------------
>>> > [INFO] Building dedup 1.0-SNAPSHOT
>>> >   [2/2]
>>> > [INFO] --------------------------------[ jar
>>> > ]---------------------------------
>>> > [INFO]
>>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>>> > (javaversion-dependencyconvergence) @ dedup ---
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
>>> > [INFO]
>>> > [INFO] es-plugins ......................................... SUCCESS [
>>> >   1.743 s]
>>> > [INFO] dedup .............................................. SUCCESS [
>>> >   0.510 s]
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] BUILD SUCCESS
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] Total time:  2.462 s
>>> > [INFO] Finished at: 2020-08-29T11:42:06+05:30
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> >
>>> > Same is working fine in maven 3.6.3.
>>> >
>>> > Debrajs-MacBook-Air:es-plugins debrajmanna$
>>> > ~/Downloads/apache-maven-3.6.3/bin/mvn validate
>>> > [INFO] Scanning for projects...
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] Reactor Build Order:
>>> > [INFO]
>>> > [INFO] es-plugins
>>> > [pom]
>>> > [INFO] dedup
>>> >   [jar]
>>> > [INFO]
>>> > [INFO] -----------------------< org.example:es-plugins
>>> >> -----------------------
>>> > [INFO] Building es-plugins 1.0-SNAPSHOT
>>> > [1/2]
>>> > [INFO] --------------------------------[ pom
>>> > ]---------------------------------
>>> > [INFO]
>>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>>> > (javaversion-dependencyconvergence) @ es-plugins ---
>>> > [INFO]
>>> > [INFO] -------------------------< org.example:dedup
>>> >> --------------------------
>>> > [INFO] Building dedup 1.0-SNAPSHOT
>>> >   [2/2]
>>> > [INFO] --------------------------------[ jar
>>> > ]---------------------------------
>>> > [INFO]
>>> > [INFO] --- maven-enforcer-plugin:3.0.0-M2:enforce
>>> > (javaversion-dependencyconvergence) @ dedup ---
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] Reactor Summary for es-plugins 1.0-SNAPSHOT:
>>> > [INFO]
>>> > [INFO] es-plugins ......................................... SUCCESS [
>>> >   1.743 s]
>>> > [INFO] dedup .............................................. SUCCESS [
>>> >   0.510 s]
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] BUILD SUCCESS
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] Total time:  2.462 s
>>> > [INFO] Finished at: 2020-08-29T11:42:06+05:30
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> >
>>>
>>>