Maven Plugin Tests Need maven-compat to Run

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Maven Plugin Tests Need maven-compat to Run

Ian Lavallee
Hi all,

I am working on getting a dependencyGraphBuilder working in its own project
with up to date dependencies (maven-resolver-api etc) as I was having a lot
of issues with some of the older code when trying to update the
dependency-plugin directly.

I used maven-plugin-testing-harness to test the plugin per
https://maven.apache.org/plugin-developers/plugin-testing.html but the test
fails unless I use maven-compat which I should avoid per
http://maven.apache.org/ref/3.6.3/maven-compat/. I've tried reading the
documentation but can't find a solution other than maven-compat. Is there a
better or newer way to test this so I can avoid maven-compat?

Github for project:
https://github.com/GoogleCloudPlatform/cloud-opensource-java/tree/DependencyGraphBuilderMojo/verboseTree-maven-plugin
(branch is DependencyGraphBuilderMojo)

Note this repo has many projects but everything is in reference to
verboseTree-maven-plugin

Any help/documentation links are greatly appreciated,
Ian
Reply | Threaded
Open this post in threaded view
|

Re: Maven Plugin Tests Need maven-compat to Run

Robert Scholte-8
That's a known issue, seeĀ https://cwiki.apache.org/confluence/display/MAVEN/Plugin+migration+to+Maven3+dependencies

Giving it the test-scope is acceptable.

thanks,
Robert

On 13-6-2020 01:56:46, Ian Lavallee <[hidden email]> wrote:
Hi all,

I am working on getting a dependencyGraphBuilder working in its own project
with up to date dependencies (maven-resolver-api etc) as I was having a lot
of issues with some of the older code when trying to update the
dependency-plugin directly.

I used maven-plugin-testing-harness to test the plugin per
https://maven.apache.org/plugin-developers/plugin-testing.html but the test
fails unless I use maven-compat which I should avoid per
http://maven.apache.org/ref/3.6.3/maven-compat/. I've tried reading the
documentation but can't find a solution other than maven-compat. Is there a
better or newer way to test this so I can avoid maven-compat?

Github for project:
https://github.com/GoogleCloudPlatform/cloud-opensource-java/tree/DependencyGraphBuilderMojo/verboseTree-maven-plugin
(branch is DependencyGraphBuilderMojo)

Note this repo has many projects but everything is in reference to
verboseTree-maven-plugin

Any help/documentation links are greatly appreciated,
Ian