Maven Dependency Plugin

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Maven Dependency Plugin

mkarg
When I am using this plugin https://maven.apache.org/plugins/maven-wrapper-plugin/ then Maven fails because it apparently cannot find needed runtime files on Maven Central. This limitation is not told on that page. Is that a bug or am I doing something wrong?
-Markus


Reply | Threaded
Open this post in threaded view
|

Re: Maven Dependency Plugin

John Patrick
If you read the opening line it talks about Maven 3.7.0, which is not
yet released.

If you want to use a maven wrapper before v3.7.0, then use this
https://github.com/takari/maven-wrapper. The upgrade from takari to
maven is easy but does allow you to change your documentation, process
and ci process instead of waiting until v3.7.0.

I did test the maven-wrapper-plugin a few months ago and I had to add
a staging repo of something like this before it worked
https://repository.apache.org/service/local/repositories/maven-XXX/content/.
But can't remember what XXX it was as I've got ~10 in my settings.xml
commented out.

John

On Mon, 26 Oct 2020 at 10:53, Markus Karg <[hidden email]> wrote:
>
> When I am using this plugin https://maven.apache.org/plugins/maven-wrapper-plugin/ then Maven fails because it apparently cannot find needed runtime files on Maven Central. This limitation is not told on that page. Is that a bug or am I doing something wrong?
> -Markus
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

AW: Maven Dependency Plugin

mkarg
Thank you for this information. It is a bit misleading that the line says "as introduced" (past tense) for a release that actually does not exist yet. Would it be OK if I file a PR to clarify that? What is the anticipated release date of Maven 3.7.0 that I could announce there?
-Markus


-----Urspr√ľngliche Nachricht-----
Von: John Patrick <[hidden email]>
Gesendet: Montag, 26. Oktober 2020 12:07
An: Maven Users List <[hidden email]>
Betreff: Re: Maven Dependency Plugin

If you read the opening line it talks about Maven 3.7.0, which is not yet released.

If you want to use a maven wrapper before v3.7.0, then use this https://github.com/takari/maven-wrapper. The upgrade from takari to maven is easy but does allow you to change your documentation, process and ci process instead of waiting until v3.7.0.

I did test the maven-wrapper-plugin a few months ago and I had to add a staging repo of something like this before it worked https://repository.apache.org/service/local/repositories/maven-XXX/content/.
But can't remember what XXX it was as I've got ~10 in my settings.xml commented out.

John

On Mon, 26 Oct 2020 at 10:53, Markus Karg <[hidden email]> wrote:
>
> When I am using this plugin https://maven.apache.org/plugins/maven-wrapper-plugin/ then Maven fails because it apparently cannot find needed runtime files on Maven Central. This limitation is not told on that page. Is that a bug or am I doing something wrong?
> -Markus
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Maven Dependency Plugin

John Patrick
I'm out of the loop regarding the 3.7.0 release schedule so can't
answer that myself, you'll need to ask the developers mailing list.

The email about maven-wrapper-plugin v3.0.1 is this one from the
developers mailing list
https://lists.apache.org/thread.html/r7cb5dd04726af22f3c69092a7057e2674383deab09caf3fe80bef98e%40%3Cdev.maven.apache.org%3E

There are a few other emails about maven-wrapper-plugin and was an
issue with v3.0.0 which is why v3.0.1 was released.

I'm 99.999% sure it was only intended to work with v3.7.0 and newer
versions only, so feel free to raise a pr.

John

On Mon, 26 Oct 2020 at 11:33, Markus Karg <[hidden email]> wrote:

>
> Thank you for this information. It is a bit misleading that the line says "as introduced" (past tense) for a release that actually does not exist yet. Would it be OK if I file a PR to clarify that? What is the anticipated release date of Maven 3.7.0 that I could announce there?
> -Markus
>
>
> -----Urspr√ľngliche Nachricht-----
> Von: John Patrick <[hidden email]>
> Gesendet: Montag, 26. Oktober 2020 12:07
> An: Maven Users List <[hidden email]>
> Betreff: Re: Maven Dependency Plugin
>
> If you read the opening line it talks about Maven 3.7.0, which is not yet released.
>
> If you want to use a maven wrapper before v3.7.0, then use this https://github.com/takari/maven-wrapper. The upgrade from takari to maven is easy but does allow you to change your documentation, process and ci process instead of waiting until v3.7.0.
>
> I did test the maven-wrapper-plugin a few months ago and I had to add a staging repo of something like this before it worked https://repository.apache.org/service/local/repositories/maven-XXX/content/.
> But can't remember what XXX it was as I've got ~10 in my settings.xml commented out.
>
> John
>
> On Mon, 26 Oct 2020 at 10:53, Markus Karg <[hidden email]> wrote:
> >
> > When I am using this plugin https://maven.apache.org/plugins/maven-wrapper-plugin/ then Maven fails because it apparently cannot find needed runtime files on Maven Central. This limitation is not told on that page. Is that a bug or am I doing something wrong?
> > -Markus
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]