Quantcast

Maven 3.5.0 and the versions plugin

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Maven 3.5.0 and the versions plugin

Mark Eggers-2
Folks,

I'm working on upgrading an environment to maven 3.5.0. With
prerequisites in pom.xml, I get the expected message:

   [WARNING] The project org.mdeggers:CSEquity:war:1.0-SNAPSHOT
   uses prerequisites which is only intended for maven-plugin projects
   but not for non maven-plugin projects. For such purposes you should
   use the maven-enforcer-plugin. See
   https://maven.apache.org/enforcer/enforcer-
   rules/requireMavenVersion.html

I then remove the prerequisites tag and replace it with the
appropriately configured enforcer plugin. The project builds cleanly.

However, one of the things that we do in Jenkins is run a series of mvn
versions:display-xxxx-updates (plugins, dependencies) and mail the
results to developers.

When I run mvn versions:display-plugin-updates, I get the expected
output as well as the following:

   [WARNING] Project does not define minimum Maven version, default is:
   2.0

   [ERROR] Project does not define required minimum version of Maven.
   [ERROR] Update the pom.xml to contain
   [ERROR]     <prerequisites>
   [ERROR]       <maven>3.0</maven>
   [ERROR]     </prerequisites>

Is there a way to resolve this? Should I file an issue with the maven
versions plugin?

. . . just my two cents
/mde/


signature.asc (484 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Maven 3.5.0 and the versions plugin

Manfred Moser-4
Yeah. Provided you have tested this with the latest version of the versions plugin and it still shows that problem...

Mark Eggers wrote on 2017-04-13 14:00:

> Folks,
>
> I'm working on upgrading an environment to maven 3.5.0. With
> prerequisites in pom.xml, I get the expected message:
>
>   [WARNING] The project org.mdeggers:CSEquity:war:1.0-SNAPSHOT
>   uses prerequisites which is only intended for maven-plugin projects
>   but not for non maven-plugin projects. For such purposes you should
>   use the maven-enforcer-plugin. See
>   https://maven.apache.org/enforcer/enforcer-
>   rules/requireMavenVersion.html
>
> I then remove the prerequisites tag and replace it with the
> appropriately configured enforcer plugin. The project builds cleanly.
>
> However, one of the things that we do in Jenkins is run a series of mvn
> versions:display-xxxx-updates (plugins, dependencies) and mail the
> results to developers.
>
> When I run mvn versions:display-plugin-updates, I get the expected
> output as well as the following:
>
>   [WARNING] Project does not define minimum Maven version, default is:
>   2.0
>
>   [ERROR] Project does not define required minimum version of Maven.
>   [ERROR] Update the pom.xml to contain
>   [ERROR]     <prerequisites>
>   [ERROR]       <maven>3.0</maven>
>   [ERROR]     </prerequisites>
>
> Is there a way to resolve this? Should I file an issue with the maven
> versions plugin?
>
> . . . just my two cents
> /mde/
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Maven 3.5.0 and the versions plugin

Karl Heinz Marbaise-3
In reply to this post by Mark Eggers-2
Hi Mark,

for the versions-maven-plugin there is already an issue for that:

https://github.com/mojohaus/versions-maven-plugin/issues/56

Currently I'm working on a large number of the issues in the
versions-maven-plugin ...

https://github.com/mojohaus/versions-maven-plugin/milestone/2?closed=1


It will take some time...

Kind regards
Karl Heinz Marbaise

On 13/04/17 23:00, Mark Eggers wrote:

> Folks,
>
> I'm working on upgrading an environment to maven 3.5.0. With
> prerequisites in pom.xml, I get the expected message:
>
>    [WARNING] The project org.mdeggers:CSEquity:war:1.0-SNAPSHOT
>    uses prerequisites which is only intended for maven-plugin projects
>    but not for non maven-plugin projects. For such purposes you should
>    use the maven-enforcer-plugin. See
>    https://maven.apache.org/enforcer/enforcer-
>    rules/requireMavenVersion.html
>
> I then remove the prerequisites tag and replace it with the
> appropriately configured enforcer plugin. The project builds cleanly.
>
> However, one of the things that we do in Jenkins is run a series of mvn
> versions:display-xxxx-updates (plugins, dependencies) and mail the
> results to developers.
>
> When I run mvn versions:display-plugin-updates, I get the expected
> output as well as the following:
>
>    [WARNING] Project does not define minimum Maven version, default is:
>    2.0
>
>    [ERROR] Project does not define required minimum version of Maven.
>    [ERROR] Update the pom.xml to contain
>    [ERROR]     <prerequisites>
>    [ERROR]       <maven>3.0</maven>
>    [ERROR]     </prerequisites>
>
> Is there a way to resolve this? Should I file an issue with the maven
> versions plugin?
>
> . . . just my two cents
> /mde/
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...