Quantcast

LigthweightHttpWagon resets system proxy properties

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

LigthweightHttpWagon resets system proxy properties

henrik.sorensen
Hi There,

Using Maven 2.1, I found that some fishy is going on in LightweightHttpWagon.java.

I carefully traced the setting and resetting of the http.proxy system properties from within the method openConnection. To my surprise the system properties were set to empty, so a resulting request for data failed.

Has somebody else expirienced similar effects ?

thanks for your help
Henrik Sorensen


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: LigthweightHttpWagon resets system proxy properties

brettporter
Administrator
They should be set on connection and unset on disconnection to try and  
minimise problems when reused.

At what point is it being used without being set?

On 15/05/2009, at 11:25 PM, <[hidden email]> <[hidden email]
 > wrote:

> Hi There,
>
> Using Maven 2.1, I found that some fishy is going on in  
> LightweightHttpWagon.java.
>
> I carefully traced the setting and resetting of the http.proxy  
> system properties from within the method openConnection. To my  
> surprise the system properties were set to empty, so a resulting  
> request for data failed.
>
> Has somebody else expirienced similar effects ?
>
> thanks for your help
> Henrik Sorensen
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...