Issue with GroupID containing an underscore

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue with GroupID containing an underscore

Jan Ancajas
Hi,

Encountered an issue using "Add Maven Artifact" with groupId having an
underscore character.  The characters after that and the underscore
itself are truncated when added as dependency in the pom.xml (e.g.
groupId="my_company" is truncated to "my" ). I haven't seen an
artifact with an "_" character in the groupId, is this supported in
maven by default? If yes,  any idea if we should support this ?


Thanks.
Reply | Threaded
Open this post in threaded view
|

Re: Issue with GroupID containing an underscore

brettporter
Administrator
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Issue with GroupID containing an underscore

Wendy Smoak
In reply to this post by Jan Ancajas
On Wed, Oct 15, 2008 at 5:05 AM, Jan Stevens Ancajas
<[hidden email]> wrote:
> Encountered an issue using "Add Maven Artifact" with groupId having an
> underscore character.  The characters after that and the underscore
> itself are truncated when added as dependency in the pom.xml (e.g.
> groupId="my_company" is truncated to "my" ). I haven't seen an
> artifact with an "_" character in the groupId, is this supported in
> maven by default? If yes,  any idea if we should support this ?

I don't think Maven itself cares about underscores, so initially this
just sounds like a bug.  However, I do see underscores used in
filenames in the the nmaven local repo, so perhaps it is a special
character for nmaven?

If there is some technical reason nmaven can't have underscores in the
groupId, we need to document it, and make sure things like the project
import feature don't suggest or generate poms with underscores in the
groupId.

--
Wendy
Reply | Threaded
Open this post in threaded view
|

Re: Issue with GroupID containing an underscore

Jan Ancajas
On Thu, Oct 16, 2008 at 6:57 AM, Wendy Smoak <[hidden email]> wrote:

> On Wed, Oct 15, 2008 at 5:05 AM, Jan Stevens Ancajas
> <[hidden email]> wrote:
>> Encountered an issue using "Add Maven Artifact" with groupId having an
>> underscore character.  The characters after that and the underscore
>> itself are truncated when added as dependency in the pom.xml (e.g.
>> groupId="my_company" is truncated to "my" ). I haven't seen an
>> artifact with an "_" character in the groupId, is this supported in
>> maven by default? If yes,  any idea if we should support this ?
>
> I don't think Maven itself cares about underscores, so initially this
> just sounds like a bug.  However, I do see underscores used in
> filenames in the the nmaven local repo, so perhaps it is a special
> character for nmaven?
>
two succeeding underscores are used as separator  between version and
groupId. I'll check if this is the cause of the issue.

> If there is some technical reason nmaven can't have underscores in the
> groupId, we need to document it, and make sure things like the project
> import feature don't suggest or generate poms with underscores in the
> groupId.
>
> --
> Wendy
>
Reply | Threaded
Open this post in threaded view
|

Re: Issue with GroupID containing an underscore

sankar.lp.gym
This post has NOT been accepted by the mailing list yet.
In reply to this post by Jan Ancajas
Try with Hypen (-)



Java Training in Chennai