How to compile java 1.5 source with maven2

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

How to compile java 1.5 source with maven2

Wendell Beckwith
Is it possible to compile jdk 1.5 code with maven2?  I have added a
pom.xml and a project.properties file to my project and set
"maven.compile.source=1.5" in the properties file, but I still get the
following error when compiling.
 
D:\dev\workspace\MyProject\src\main\java\com\intervoice\core\internal\ap
plication\Understand.java:[29,-1]  generics are not supported in -source
1.3
 
Wb
 

This e-mail transmission may contain information that is proprietary, privileged and/or confidential and is intended exclusively for the person(s) to whom it is addressed. Any use, copying, retention or disclosure by any person other than the intended recipient or the intended recipient's designees is strictly prohibited. If you are the intended recipient, you must treat the information in confidence and in accordance with all laws related to the privacy and confidentiality of such information.  If you are not the intended recipient or their designee, please notify the sender immediately by return e-mail and delete all copies of this email, including all attachments.
Reply | Threaded
Open this post in threaded view
|

Re: How to compile java 1.5 source with maven2

Hugo Palma
Put this in your pom.xml file:

<build>
<plugins>
            <plugin>
                <artifactId>maven-compiler-plugin</artifactId>
                <configuration>
                    <source>1.5</source>
                    <target>1.5</target>
                </configuration>
            </plugin>
        </plugins>
</build>

Cheers

Hugo



Wendell Beckwith wrote:

>Is it possible to compile jdk 1.5 code with maven2?  I have added a
>pom.xml and a project.properties file to my project and set
>"maven.compile.source=1.5" in the properties file, but I still get the
>following error when compiling.
>
>D:\dev\workspace\MyProject\src\main\java\com\intervoice\core\internal\ap
>plication\Understand.java:[29,-1]  generics are not supported in -source
>1.3
>
>Wb
>
>
>This e-mail transmission may contain information that is proprietary, privileged and/or confidential and is intended exclusively for the person(s) to whom it is addressed. Any use, copying, retention or disclosure by any person other than the intended recipient or the intended recipient's designees is strictly prohibited. If you are the intended recipient, you must treat the information in confidence and in accordance with all laws related to the privacy and confidentiality of such information.  If you are not the intended recipient or their designee, please notify the sender immediately by return e-mail and delete all copies of this email, including all attachments.
>  
>
Reply | Threaded
Open this post in threaded view
|

RE: How to compile java 1.5 source with maven2

Wendell Beckwith
In reply to this post by Wendell Beckwith
That worked perfectly!! Thnx.


Wb

-----Original Message-----
From: Hugo Palma [mailto:[hidden email]]
Sent: Friday, May 27, 2005 11:21 AM
To: Maven Users List
Subject: Re: How to compile java 1.5 source with maven2

Put this in your pom.xml file:

<build>
<plugins>
            <plugin>
                <artifactId>maven-compiler-plugin</artifactId>
                <configuration>
                    <source>1.5</source>
                    <target>1.5</target>
                </configuration>
            </plugin>
        </plugins>
</build>

Cheers

Hugo



Wendell Beckwith wrote:

>Is it possible to compile jdk 1.5 code with maven2?  I have added a
>pom.xml and a project.properties file to my project and set
>"maven.compile.source=1.5" in the properties file, but I still get the
>following error when compiling.
>
>D:\dev\workspace\MyProject\src\main\java\com\intervoice\core\internal\a
>p plication\Understand.java:[29,-1]  generics are not supported in
>-source
>1.3
>
>Wb
>
>
>This e-mail transmission may contain information that is proprietary,
privileged and/or confidential and is intended exclusively for the
person(s) to whom it is addressed. Any use, copying, retention or
disclosure by any person other than the intended recipient or the
intended recipient's designees is strictly prohibited. If you are the
intended recipient, you must treat the information in confidence and in
accordance with all laws related to the privacy and confidentiality of
such information.  If you are not the intended recipient or their
designee, please notify the sender immediately by return e-mail and
delete all copies of this email, including all attachments.
>  
>

This e-mail transmission may contain information that is proprietary, privileged and/or confidential and is intended exclusively for the person(s) to whom it is addressed. Any use, copying, retention or disclosure by any person other than the intended recipient or the intended recipient's designees is strictly prohibited. If you are the intended recipient, you must treat the information in confidence and in accordance with all laws related to the privacy and confidentiality of such information.  If you are not the intended recipient or their designee, please notify the sender immediately by return e-mail and delete all copies of this email, including all attachments.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]