[GitHub] oleg-nenashev opened a new pull request #25: MENFORCER-276 - Support ignoring dependency scopes in RequireUpperBoundDeps

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[GitHub] oleg-nenashev opened a new pull request #25: MENFORCER-276 - Support ignoring dependency scopes in RequireUpperBoundDeps

GitBox
oleg-nenashev opened a new pull request #25: MENFORCER-276 - Support ignoring dependency scopes in RequireUpperBoundDeps
URL: https://github.com/apache/maven-enforcer/pull/25
 
 
   We have recently adopted `RequireUpperBoundDeps` in the Jenkins project (https://github.com/jenkinsci/plugin-pom/pull/67). In order to implement it, Jesse Glick added a support of ignoring particular dependencies in [MENFORCER-273](https://issues.apache.org/jira/browse/MENFORCER-273).
   
   Sometimes we declare dependencies between plugins for testing purposes (scope=test), and in such case RequireUpperBoundDeps fails the build if there is a test dependency conflicting with the main code. Although it may cause instability of tests (including false positive results), it does not really impact the distributable package in our case.
   
   I propose to add another option for filtering of dependency scopes. This pull request also adds some unit tests for `RequireUpperBoundDeps`. Previously it had integration tests only.
   
   https://issues.apache.org/jira/browse/MENFORCER-276
   
   @reviewbybees @jglick @stephenc

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
[hidden email]


With regards,
Apache Git Services

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]