Failures building Eclipse 4.13 with maven-3.6.2

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Failures building Eclipse 4.13 with maven-3.6.2

Jonathan Chen
Hi,

I'm currently attempting to build Eclipse 4.13 from source using
maven-3.6.2, and I'm seeing these current failures:
[INFO] Scanning for projects...
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[FATAL] Non-readable POM
/home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation10/.polyglot.build.properties:
input contained no data @
[FATAL] Non-readable POM
/home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation11/.polyglot.build.properties:
input contained no data @
[FATAL] Non-readable POM
/home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.feature/.polyglot.build.properties:
input contained no data @
[FATAL] Non-readable POM
/home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se12/.polyglot.build.properties:
input contained no data @
[FATAL] Non-readable POM
/home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se13/.polyglot.build.properties:
input contained no data @
[FATAL] Non-readable POM
/home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se14/.polyglot.build.properties:
input contained no data @
[FATAL] Non-readable POM
/home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se15/.polyglot.build.properties:
input contained no data @
[FATAL] Non-readable POM
/home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase16/.polyglot.build.properties:
input contained no data @
[FATAL] Non-readable POM
/home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase17/.polyglot.build.properties:
input contained no data @
...

It appears that the pom-less builds are failing due to a missing
.polyglot.build.properties. These are transient files that are removed
once the compiling JVM exits. Something in the 3.6.2 lifecycle has
changed such that the files are not staying long enough to be
available for dependency-resolution.

If I downgrade to maven-3.6.1 or maven-3.6.0, these errors do not arise.

Cheers.
--
Jonathan Chen <[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Failures building Eclipse 4.13 with maven-3.6.2

Jeff MAURY-2
This is a know case between tycho pomless and maven 3.6.2

Le sam. 14 sept. 2019 à 05:26, Jonathan Chen <[hidden email]> a écrit :

> Hi,
>
> I'm currently attempting to build Eclipse 4.13 from source using
> maven-3.6.2, and I'm seeing these current failures:
> [INFO] Scanning for projects...
> [ERROR] [ERROR] Some problems were encountered while processing the POMs:
> [FATAL] Non-readable POM
>
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation10/.polyglot.build.properties:
> input contained no data @
> [FATAL] Non-readable POM
>
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation11/.polyglot.build.properties:
> input contained no data @
> [FATAL] Non-readable POM
>
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.feature/.polyglot.build.properties:
> input contained no data @
> [FATAL] Non-readable POM
>
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se12/.polyglot.build.properties:
> input contained no data @
> [FATAL] Non-readable POM
>
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se13/.polyglot.build.properties:
> input contained no data @
> [FATAL] Non-readable POM
>
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se14/.polyglot.build.properties:
> input contained no data @
> [FATAL] Non-readable POM
>
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se15/.polyglot.build.properties:
> input contained no data @
> [FATAL] Non-readable POM
>
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase16/.polyglot.build.properties:
> input contained no data @
> [FATAL] Non-readable POM
>
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase17/.polyglot.build.properties:
> input contained no data @
> ...
>
> It appears that the pom-less builds are failing due to a missing
> .polyglot.build.properties. These are transient files that are removed
> once the compiling JVM exits. Something in the 3.6.2 lifecycle has
> changed such that the files are not staying long enough to be
> available for dependency-resolution.
>
> If I downgrade to maven-3.6.1 or maven-3.6.0, these errors do not arise.
>
> Cheers.
> --
> Jonathan Chen <[hidden email]>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Failures building Eclipse 4.13 with maven-3.6.2

Jonathan Chen
Hi,

Thanks for that. Is there a JIRA reference for this bug?

Cheers.
--
Jonathan Chen <[hidden email]>

On Sat, 14 Sep 2019 at 17:39, Jeff MAURY <[hidden email]> wrote:

>
> This is a know case between tycho pomless and maven 3.6.2
>
> Le sam. 14 sept. 2019 à 05:26, Jonathan Chen <[hidden email]> a écrit :
>
> > Hi,
> >
> > I'm currently attempting to build Eclipse 4.13 from source using
> > maven-3.6.2, and I'm seeing these current failures:
> > [INFO] Scanning for projects...
> > [ERROR] [ERROR] Some problems were encountered while processing the POMs:
> > [FATAL] Non-readable POM
> >
> > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation10/.polyglot.build.properties:
> > input contained no data @
> > [FATAL] Non-readable POM
> >
> > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation11/.polyglot.build.properties:
> > input contained no data @
> > [FATAL] Non-readable POM
> >
> > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.feature/.polyglot.build.properties:
> > input contained no data @
> > [FATAL] Non-readable POM
> >
> > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se12/.polyglot.build.properties:
> > input contained no data @
> > [FATAL] Non-readable POM
> >
> > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se13/.polyglot.build.properties:
> > input contained no data @
> > [FATAL] Non-readable POM
> >
> > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se14/.polyglot.build.properties:
> > input contained no data @
> > [FATAL] Non-readable POM
> >
> > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se15/.polyglot.build.properties:
> > input contained no data @
> > [FATAL] Non-readable POM
> >
> > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase16/.polyglot.build.properties:
> > input contained no data @
> > [FATAL] Non-readable POM
> >
> > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase17/.polyglot.build.properties:
> > input contained no data @
> > ...
> >
> > It appears that the pom-less builds are failing due to a missing
> > .polyglot.build.properties. These are transient files that are removed
> > once the compiling JVM exits. Something in the 3.6.2 lifecycle has
> > changed such that the files are not staying long enough to be
> > available for dependency-resolution.
> >
> > If I downgrade to maven-3.6.1 or maven-3.6.0, these errors do not arise.
> >
> > Cheers.
> > --
> > Jonathan Chen <[hidden email]>
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Failures building Eclipse 4.13 with maven-3.6.2

Jonathan Chen
Hi,

I didn't find a matching issue, so I raised MNG-6765 so that it can be tracked.
https://issues.apache.org/jira/browse/MNG-6765

Cheers.
--
Jonathan Chen <[hidden email]>

On Sat, 14 Sep 2019 at 19:47, Jonathan Chen <[hidden email]> wrote:

>
> Hi,
>
> Thanks for that. Is there a JIRA reference for this bug?
>
> Cheers.
> --
> Jonathan Chen <[hidden email]>
>
> On Sat, 14 Sep 2019 at 17:39, Jeff MAURY <[hidden email]> wrote:
> >
> > This is a know case between tycho pomless and maven 3.6.2
> >
> > Le sam. 14 sept. 2019 à 05:26, Jonathan Chen <[hidden email]> a écrit :
> >
> > > Hi,
> > >
> > > I'm currently attempting to build Eclipse 4.13 from source using
> > > maven-3.6.2, and I'm seeing these current failures:
> > > [INFO] Scanning for projects...
> > > [ERROR] [ERROR] Some problems were encountered while processing the POMs:
> > > [FATAL] Non-readable POM
> > >
> > > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation10/.polyglot.build.properties:
> > > input contained no data @
> > > [FATAL] Non-readable POM
> > >
> > > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation11/.polyglot.build.properties:
> > > input contained no data @
> > > [FATAL] Non-readable POM
> > >
> > > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.feature/.polyglot.build.properties:
> > > input contained no data @
> > > [FATAL] Non-readable POM
> > >
> > > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se12/.polyglot.build.properties:
> > > input contained no data @
> > > [FATAL] Non-readable POM
> > >
> > > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se13/.polyglot.build.properties:
> > > input contained no data @
> > > [FATAL] Non-readable POM
> > >
> > > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se14/.polyglot.build.properties:
> > > input contained no data @
> > > [FATAL] Non-readable POM
> > >
> > > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se15/.polyglot.build.properties:
> > > input contained no data @
> > > [FATAL] Non-readable POM
> > >
> > > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase16/.polyglot.build.properties:
> > > input contained no data @
> > > [FATAL] Non-readable POM
> > >
> > > /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase17/.polyglot.build.properties:
> > > input contained no data @
> > > ...
> > >
> > > It appears that the pom-less builds are failing due to a missing
> > > .polyglot.build.properties. These are transient files that are removed
> > > once the compiling JVM exits. Something in the 3.6.2 lifecycle has
> > > changed such that the files are not staying long enough to be
> > > available for dependency-resolution.
> > >
> > > If I downgrade to maven-3.6.1 or maven-3.6.0, these errors do not arise.
> > >
> > > Cheers.
> > > --
> > > Jonathan Chen <[hidden email]>
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Failures building Eclipse 4.13 with maven-3.6.2

Enrico Olivelli
Any volunteer to work on a fix?

Enrico

Il sab 14 set 2019, 10:08 Jonathan Chen <[hidden email]> ha scritto:

> Hi,
>
> I didn't find a matching issue, so I raised MNG-6765 so that it can be
> tracked.
> https://issues.apache.org/jira/browse/MNG-6765
>
> Cheers.
> --
> Jonathan Chen <[hidden email]>
>
> On Sat, 14 Sep 2019 at 19:47, Jonathan Chen <[hidden email]> wrote:
> >
> > Hi,
> >
> > Thanks for that. Is there a JIRA reference for this bug?
> >
> > Cheers.
> > --
> > Jonathan Chen <[hidden email]>
> >
> > On Sat, 14 Sep 2019 at 17:39, Jeff MAURY <[hidden email]> wrote:
> > >
> > > This is a know case between tycho pomless and maven 3.6.2
> > >
> > > Le sam. 14 sept. 2019 à 05:26, Jonathan Chen <[hidden email]> a
> écrit :
> > >
> > > > Hi,
> > > >
> > > > I'm currently attempting to build Eclipse 4.13 from source using
> > > > maven-3.6.2, and I'm seeing these current failures:
> > > > [INFO] Scanning for projects...
> > > > [ERROR] [ERROR] Some problems were encountered while processing the
> POMs:
> > > > [FATAL] Non-readable POM
> > > >
> > > >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation10/.polyglot.build.properties:
> > > > input contained no data @
> > > > [FATAL] Non-readable POM
> > > >
> > > >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation11/.polyglot.build.properties:
> > > > input contained no data @
> > > > [FATAL] Non-readable POM
> > > >
> > > >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.feature/.polyglot.build.properties:
> > > > input contained no data @
> > > > [FATAL] Non-readable POM
> > > >
> > > >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se12/.polyglot.build.properties:
> > > > input contained no data @
> > > > [FATAL] Non-readable POM
> > > >
> > > >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se13/.polyglot.build.properties:
> > > > input contained no data @
> > > > [FATAL] Non-readable POM
> > > >
> > > >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se14/.polyglot.build.properties:
> > > > input contained no data @
> > > > [FATAL] Non-readable POM
> > > >
> > > >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se15/.polyglot.build.properties:
> > > > input contained no data @
> > > > [FATAL] Non-readable POM
> > > >
> > > >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase16/.polyglot.build.properties:
> > > > input contained no data @
> > > > [FATAL] Non-readable POM
> > > >
> > > >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase17/.polyglot.build.properties:
> > > > input contained no data @
> > > > ...
> > > >
> > > > It appears that the pom-less builds are failing due to a missing
> > > > .polyglot.build.properties. These are transient files that are
> removed
> > > > once the compiling JVM exits. Something in the 3.6.2 lifecycle has
> > > > changed such that the files are not staying long enough to be
> > > > available for dependency-resolution.
> > > >
> > > > If I downgrade to maven-3.6.1 or maven-3.6.0, these errors do not
> arise.
> > > >
> > > > Cheers.
> > > > --
> > > > Jonathan Chen <[hidden email]>
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail: [hidden email]
> > > > For additional commands, e-mail: [hidden email]
> > > >
> > > >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Failures building Eclipse 4.13 with maven-3.6.2

Matthieu BROUILLARD-3
Hello,

it looks like maven-3.6.2 really introduced a non compatible change with
[core?] extensions and not just on polyglot-maven.

In my own core extension project (jgitver-maven-plugin), when using
maven-3.6.2, the ModelProcessor that I provide is not called anymore.
Hope that helps to track down the culprit change.

Matthieu

On Sat, Sep 14, 2019 at 10:53 AM Enrico Olivelli <[hidden email]>
wrote:

> Any volunteer to work on a fix?
>
> Enrico
>
> Il sab 14 set 2019, 10:08 Jonathan Chen <[hidden email]> ha scritto:
>
> > Hi,
> >
> > I didn't find a matching issue, so I raised MNG-6765 so that it can be
> > tracked.
> > https://issues.apache.org/jira/browse/MNG-6765
> >
> > Cheers.
> > --
> > Jonathan Chen <[hidden email]>
> >
> > On Sat, 14 Sep 2019 at 19:47, Jonathan Chen <[hidden email]> wrote:
> > >
> > > Hi,
> > >
> > > Thanks for that. Is there a JIRA reference for this bug?
> > >
> > > Cheers.
> > > --
> > > Jonathan Chen <[hidden email]>
> > >
> > > On Sat, 14 Sep 2019 at 17:39, Jeff MAURY <[hidden email]> wrote:
> > > >
> > > > This is a know case between tycho pomless and maven 3.6.2
> > > >
> > > > Le sam. 14 sept. 2019 à 05:26, Jonathan Chen <[hidden email]> a
> > écrit :
> > > >
> > > > > Hi,
> > > > >
> > > > > I'm currently attempting to build Eclipse 4.13 from source using
> > > > > maven-3.6.2, and I'm seeing these current failures:
> > > > > [INFO] Scanning for projects...
> > > > > [ERROR] [ERROR] Some problems were encountered while processing the
> > POMs:
> > > > > [FATAL] Non-readable POM
> > > > >
> > > > >
> >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation10/.polyglot.build.properties:
> > > > > input contained no data @
> > > > > [FATAL] Non-readable POM
> > > > >
> > > > >
> >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.cdcfoundation11/.polyglot.build.properties:
> > > > > input contained no data @
> > > > > [FATAL] Non-readable POM
> > > > >
> > > > >
> >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.feature/.polyglot.build.properties:
> > > > > input contained no data @
> > > > > [FATAL] Non-readable POM
> > > > >
> > > > >
> >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se12/.polyglot.build.properties:
> > > > > input contained no data @
> > > > > [FATAL] Non-readable POM
> > > > >
> > > > >
> >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se13/.polyglot.build.properties:
> > > > > input contained no data @
> > > > > [FATAL] Non-readable POM
> > > > >
> > > > >
> >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se14/.polyglot.build.properties:
> > > > > input contained no data @
> > > > > [FATAL] Non-readable POM
> > > > >
> > > > >
> >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.j2se15/.polyglot.build.properties:
> > > > > input contained no data @
> > > > > [FATAL] Non-readable POM
> > > > >
> > > > >
> >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase16/.polyglot.build.properties:
> > > > > input contained no data @
> > > > > [FATAL] Non-readable POM
> > > > >
> > > > >
> >
> /home/jonc/work/ports/freebsd-eclipse/eclipse.platform.releng.aggregator/eclipse.pde.ui/apitools/org.eclipse.pde.api.tools.ee.javase17/.polyglot.build.properties:
> > > > > input contained no data @
> > > > > ...
> > > > >
> > > > > It appears that the pom-less builds are failing due to a missing
> > > > > .polyglot.build.properties. These are transient files that are
> > removed
> > > > > once the compiling JVM exits. Something in the 3.6.2 lifecycle has
> > > > > changed such that the files are not staying long enough to be
> > > > > available for dependency-resolution.
> > > > >
> > > > > If I downgrade to maven-3.6.1 or maven-3.6.0, these errors do not
> > arise.
> > > > >
> > > > > Cheers.
> > > > > --
> > > > > Jonathan Chen <[hidden email]>
> > > > >
> > > > >
> ---------------------------------------------------------------------
> > > > > To unsubscribe, e-mail: [hidden email]
> > > > > For additional commands, e-mail: [hidden email]
> > > > >
> > > > >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>