Failure to find groupId>org.apache.maven.plugins:maven-source-plugin:jar:3.0.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Failure to find groupId>org.apache.maven.plugins:maven-source-plugin:jar:3.0.1

munna
This post has NOT been accepted by the mailing list yet.
This post was updated on .
POM file shows me the error below

Failure to find groupId>org.apache.maven.plugins:maven-source-plugin:jar:3.0.1 in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced

I have downloaded plugins into my local maven repository (/Users/krish/.m2/repository).

Please see my pom file below

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
  <modelVersion>4.0.0</modelVersion>

  <groupId>com.myqisinfotech.tests.pac</groupId>
  <artifactId>PAC</artifactId>
  <version>0.0.1-SNAPSHOT</version>
  <packaging>jar</packaging>
    <name>PAC</name>
 <url>http://maven.apache.org</url>

<build>
        <plugins>
                     <plugin>
                                        <groupId>org.apache.maven.plugins</groupId>
                                  <artifactId>maven-surefire-plugin</artifactId>
                                  <version>2.19.1</version>
                        <configuration>
                  <additionalClasspathElements>
                    <additionalClasspathElement>${project.basedir}</additionalClasspathElement>
                    </additionalClasspathElements>
                  </configuration>
                </plugin>               

                        <plugin>
                    <groupId>groupId>org.apache.maven.plugins</groupId>
              <artifactId>maven-source-plugin</artifactId>
              <version>3.0.1</version> 
                  <executions>
                                                <execution>
                                                        <id>attach-sources</id>
                  <goals>
                  <goal>jar</goal>
                  </goals>
                  </execution>
                  </executions>
                        </plugin>
        </plugins>
</build>   

 <dependencies>

    <dependency>
  <groupId>junit</groupId>
  <artifactId>junit</artifactId>
  <version>4.12</version>
  </dependency>
  <dependency>
  <groupId>log4j</groupId>
  <artifactId>log4j</artifactId>
  <version>1.2.17</version>
  </dependency>
  <dependency>
  <groupId>com.googlecode.json-simple</groupId>
  <artifactId>json-simple</artifactId>
  <version>1.1.1</version>
  </dependency>
   <dependency>
        <groupId>org.seleniumhq.selenium</groupId>
        <artifactId>selenium-java</artifactId>
        <version>3.0.1</version>
    </dependency> 
     <dependency>
        <groupId>org.seleniumhq.selenium</groupId>
        <artifactId>selenium-server</artifactId>
        <version>3.0.1</version>
    </dependency>
  <dependency>
  <groupId>org.xerial</groupId>
  <artifactId>sqlite-jdbc</artifactId>
  <version>3.7.2</version>
  </dependency>
 <dependency>
  <groupId>commons-codec</groupId>
  <artifactId>commons-codec</artifactId>
  <version>1.3</version>
  </dependency>
  <dependency>
    <groupId>javax.mail</groupId>
    <artifactId>mail</artifactId>
    <version>1.4.7</version>
</dependency>
  </dependencies>
 
  <properties>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    <maven.compiler.source>1.7</maven.compiler.source>
    <maven.compiler.target>1.7</maven.compiler.target>
  </properties>

</project>
Loading...