Failsafe plugin support for Junit 5

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Failsafe plugin support for Junit 5

Lavanya Paleti
Hi,

I am Sri, working as a java developer.  Have an integration test updated to Junit 5 and trying to run it using the maven command.
The failsafe doesn’t pick up the test.
Included the following dependency to the failsafe plugin after reading an article from StackOverflow.
     <dependency>
            <groupId>org.junit.platform</groupId>
            <artifactId>junit-platform-surefire-provider</artifactId>
            <version>${junit.platform.version}</version>
        </dependency>
Maven apache site says the providers are supported till Junit 4.x and provided the algorithm how it picks the providers.

Is it the same provider for Junit 5?

Thanks,
Sri