Error with mvn site:stage-deploy

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Error with mvn site:stage-deploy

Enrico Olivelli
Hi,
I have this error with Maven 3.6.0 and maven-site-plugin 3.7.1 and
wagon-webdav-jackrabbit 3.3.1

 java.lang.NoSuchMethodError:
org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.getBufferCapacityForTransfer(J)I
    at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.access$000
(AbstractHttpClientWagon.java:112)
    at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon$RequestEntityImplementation.writeTo
(AbstractHttpClientWagon.java:185)
    at org.apache.http.impl.DefaultBHttpClientConnection.sendRequestEntity
(DefaultBHttpClientConnection.java:156)


Is there anyworkaround ?
I am trying to force all of the dependencies in the site plugin

<plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-site-plugin</artifactId>
    <version>3.7.1</version>
    <dependencies>
    <dependency>
      <groupId>org.apache.maven.wagon</groupId>
      <artifactId>wagon-http</artifactId>
      <version>3.3.1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.maven.wagon</groupId>
      <artifactId>wagon</artifactId>
      <version>3.3.1</version>
      <type>pom</type>
    </dependency>
    <dependency>
      <groupId>org.apache.maven.wagon</groupId>
      <artifactId>wagon-http-shared</artifactId>
      <version>3.3.1</version>
    </dependency>
    <dependency>
      <groupId>org.apache.maven.wagon</groupId>
      <artifactId>wagon-webdav-jackrabbit</artifactId>
      <version>3.3.1</version>
    </dependency>
          </dependencies>

But no result...

Thanks

Enrico

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Error with mvn site:stage-deploy

Konrad Windszus
This seems to be related to the merged PR from https://github.com/apache/maven-wagon/pull/51/files <https://github.com/apache/maven-wagon/pull/51/files>.
Not sure why the error happens though...

> On 8. Jan 2019, at 17:27, Enrico Olivelli <[hidden email]> wrote:
>
> Hi,
> I have this error with Maven 3.6.0 and maven-site-plugin 3.7.1 and
> wagon-webdav-jackrabbit 3.3.1
>
> java.lang.NoSuchMethodError:
> org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.getBufferCapacityForTransfer(J)I
>    at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.access$000
> (AbstractHttpClientWagon.java:112)
>    at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon$RequestEntityImplementation.writeTo
> (AbstractHttpClientWagon.java:185)
>    at org.apache.http.impl.DefaultBHttpClientConnection.sendRequestEntity
> (DefaultBHttpClientConnection.java:156)
>
>
> Is there anyworkaround ?
> I am trying to force all of the dependencies in the site plugin
>
> <plugin>
>    <groupId>org.apache.maven.plugins</groupId>
>    <artifactId>maven-site-plugin</artifactId>
>    <version>3.7.1</version>
>    <dependencies>
>    <dependency>
>      <groupId>org.apache.maven.wagon</groupId>
>      <artifactId>wagon-http</artifactId>
>      <version>3.3.1</version>
>    </dependency>
>    <dependency>
>      <groupId>org.apache.maven.wagon</groupId>
>      <artifactId>wagon</artifactId>
>      <version>3.3.1</version>
>      <type>pom</type>
>    </dependency>
>    <dependency>
>      <groupId>org.apache.maven.wagon</groupId>
>      <artifactId>wagon-http-shared</artifactId>
>      <version>3.3.1</version>
>    </dependency>
>    <dependency>
>      <groupId>org.apache.maven.wagon</groupId>
>      <artifactId>wagon-webdav-jackrabbit</artifactId>
>      <version>3.3.1</version>
>    </dependency>
>          </dependencies>
>
> But no result...
>
> Thanks
>
> Enrico
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

Reply | Threaded
Open this post in threaded view
|

Aw: Re: Error with mvn site:stage-deploy

Michael Osipov-3
Please file an issue, I will take a look.

> Gesendet: Dienstag, 08. Januar 2019 um 17:37 Uhr
> Von: "Konrad Windszus" <[hidden email]>
> An: "Maven Users List" <[hidden email]>
> Betreff: Re: Error with mvn site:stage-deploy
>
> This seems to be related to the merged PR from https://github.com/apache/maven-wagon/pull/51/files <https://github.com/apache/maven-wagon/pull/51/files>.
> Not sure why the error happens though...
>
> > On 8. Jan 2019, at 17:27, Enrico Olivelli <[hidden email]> wrote:
> >
> > Hi,
> > I have this error with Maven 3.6.0 and maven-site-plugin 3.7.1 and
> > wagon-webdav-jackrabbit 3.3.1
> >
> > java.lang.NoSuchMethodError:
> > org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.getBufferCapacityForTransfer(J)I
> >    at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.access$000
> > (AbstractHttpClientWagon.java:112)
> >    at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon$RequestEntityImplementation.writeTo
> > (AbstractHttpClientWagon.java:185)
> >    at org.apache.http.impl.DefaultBHttpClientConnection.sendRequestEntity
> > (DefaultBHttpClientConnection.java:156)
> >
> >
> > Is there anyworkaround ?
> > I am trying to force all of the dependencies in the site plugin
> >
> > <plugin>
> >    <groupId>org.apache.maven.plugins</groupId>
> >    <artifactId>maven-site-plugin</artifactId>
> >    <version>3.7.1</version>
> >    <dependencies>
> >    <dependency>
> >      <groupId>org.apache.maven.wagon</groupId>
> >      <artifactId>wagon-http</artifactId>
> >      <version>3.3.1</version>
> >    </dependency>
> >    <dependency>
> >      <groupId>org.apache.maven.wagon</groupId>
> >      <artifactId>wagon</artifactId>
> >      <version>3.3.1</version>
> >      <type>pom</type>
> >    </dependency>
> >    <dependency>
> >      <groupId>org.apache.maven.wagon</groupId>
> >      <artifactId>wagon-http-shared</artifactId>
> >      <version>3.3.1</version>
> >    </dependency>
> >    <dependency>
> >      <groupId>org.apache.maven.wagon</groupId>
> >      <artifactId>wagon-webdav-jackrabbit</artifactId>
> >      <version>3.3.1</version>
> >    </dependency>
> >          </dependencies>
> >
> > But no result...
> >
> > Thanks
> >
> > Enrico
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Re: Error with mvn site:stage-deploy

Enrico Olivelli
Il giorno mar 8 gen 2019 alle ore 19:28 Michael Osipov
<[hidden email]> ha scritto:
>
> Please file an issue, I will take a look.

Here it is
https://issues.apache.org/jira/browse/MSITE-832

Thank you
Enrico


>
> > Gesendet: Dienstag, 08. Januar 2019 um 17:37 Uhr
> > Von: "Konrad Windszus" <[hidden email]>
> > An: "Maven Users List" <[hidden email]>
> > Betreff: Re: Error with mvn site:stage-deploy
> >
> > This seems to be related to the merged PR from https://github.com/apache/maven-wagon/pull/51/files <https://github.com/apache/maven-wagon/pull/51/files>.
> > Not sure why the error happens though...
> >
> > > On 8. Jan 2019, at 17:27, Enrico Olivelli <[hidden email]> wrote:
> > >
> > > Hi,
> > > I have this error with Maven 3.6.0 and maven-site-plugin 3.7.1 and
> > > wagon-webdav-jackrabbit 3.3.1
> > >
> > > java.lang.NoSuchMethodError:
> > > org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.getBufferCapacityForTransfer(J)I
> > >    at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.access$000
> > > (AbstractHttpClientWagon.java:112)
> > >    at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon$RequestEntityImplementation.writeTo
> > > (AbstractHttpClientWagon.java:185)
> > >    at org.apache.http.impl.DefaultBHttpClientConnection.sendRequestEntity
> > > (DefaultBHttpClientConnection.java:156)
> > >
> > >
> > > Is there anyworkaround ?
> > > I am trying to force all of the dependencies in the site plugin
> > >
> > > <plugin>
> > >    <groupId>org.apache.maven.plugins</groupId>
> > >    <artifactId>maven-site-plugin</artifactId>
> > >    <version>3.7.1</version>
> > >    <dependencies>
> > >    <dependency>
> > >      <groupId>org.apache.maven.wagon</groupId>
> > >      <artifactId>wagon-http</artifactId>
> > >      <version>3.3.1</version>
> > >    </dependency>
> > >    <dependency>
> > >      <groupId>org.apache.maven.wagon</groupId>
> > >      <artifactId>wagon</artifactId>
> > >      <version>3.3.1</version>
> > >      <type>pom</type>
> > >    </dependency>
> > >    <dependency>
> > >      <groupId>org.apache.maven.wagon</groupId>
> > >      <artifactId>wagon-http-shared</artifactId>
> > >      <version>3.3.1</version>
> > >    </dependency>
> > >    <dependency>
> > >      <groupId>org.apache.maven.wagon</groupId>
> > >      <artifactId>wagon-webdav-jackrabbit</artifactId>
> > >      <version>3.3.1</version>
> > >    </dependency>
> > >          </dependencies>
> > >
> > > But no result...
> > >
> > > Thanks
> > >
> > > Enrico
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]