Error when trying to download an artifact

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Error when trying to download an artifact

Menke, Mikolaj
Hello,

One of our developers reports that there is the following error in maven when trying to download an artifact:

[ERROR]     Unresolveable build extension: Plugin org.apache.servicemix.tooling:jbi-maven-plugin:3.3.1.24-fuse or one of its dependencies co
uld not be resolved: Failed to collect dependencies for org.apache.servicemix.tooling:jbi-maven-plugin:jar:3.3.1.24-fuse (): Failed to read
artifact descriptor for org.apache.xbean:xbean-server:jar:3.1.0.2-fuse: Could not transfer artifact org.apache.xbean:xbean-server:pom:3.1.0.
2-fuse from/to Public Repo (http://our.nexus.host/content/groups/public): Checksum validation failed, no checksums available from the
 repository -> [Help 2]

I can download the "xbean-server-3.1.0.2-fuse.pom" file with any http client so where is the problem? Is it a problem with Nexus or somewhere else?

Regards,
Mikolaj Menke


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Error when trying to download an artifact

Ron Wheeler
Where are you getting this from? It is not in Maven Central according to
my Nexus.
There is a 3.1, 3.2 and 3.3 of org.apache.xbean:xbean-server

  There is no
org.apache.servicemix.tooling:jbi-maven-plugin:3.3.1.24-fuse either.
  3.2.3, 4.0, 4.1,4.2 exist

Perhaps you have picked up a branch that died and was never released
officially.

You might want to upgrade or ask the servicemix people.


Ron

On 02/09/2014 10:22 AM, Menke, Mikolaj wrote:

> Hello,
>
> One of our developers reports that there is the following error in maven when trying to download an artifact:
>
> [ERROR]     Unresolveable build extension: Plugin org.apache.servicemix.tooling:jbi-maven-plugin:3.3.1.24-fuse or one of its dependencies co
> uld not be resolved: Failed to collect dependencies for org.apache.servicemix.tooling:jbi-maven-plugin:jar:3.3.1.24-fuse (): Failed to read
> artifact descriptor for org.apache.xbean:xbean-server:jar:3.1.0.2-fuse: Could not transfer artifact org.apache.xbean:xbean-server:pom:3.1.0.
> 2-fuse from/to Public Repo (http://our.nexus.host/content/groups/public): Checksum validation failed, no checksums available from the
>   repository -> [Help 2]
>
> I can download the "xbean-server-3.1.0.2-fuse.pom" file with any http client so where is the problem? Is it a problem with Nexus or somewhere else?
>
> Regards,
> Mikolaj Menke
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Ron Wheeler
President
Artifact Software Inc
email: [hidden email]
skype: ronaldmwheeler
phone: 866-970-2435, ext 102


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Error when trying to download an artifact

Rich Seddon
In reply to this post by Menke, Mikolaj
It's failing because "org/apache/xbean/xbean-server/3.1.0.2-fuse/xbean-server-3.1.0.2-fuse.pom.sha1" can't be downloaded.

I assume you're using http://repo.fusesource.com/nexus/content/groups/public as your proxy's remote URL?  If so, the file is there:


On Tue, Sep 2, 2014 at 9:22 AM, Menke, Mikolaj <[hidden email]> wrote:
Hello,

One of our developers reports that there is the following error in maven when trying to download an artifact:

[ERROR]     Unresolveable build extension: Plugin org.apache.servicemix.tooling:jbi-maven-plugin:3.3.1.24-fuse or one of its dependencies co
uld not be resolved: Failed to collect dependencies for org.apache.servicemix.tooling:jbi-maven-plugin:jar:3.3.1.24-fuse (): Failed to read
artifact descriptor for org.apache.xbean:xbean-server:jar:3.1.0.2-fuse: Could not transfer artifact org.apache.xbean:xbean-server:pom:3.1.0.
2-fuse from/to Public Repo (http://our.nexus.host/content/groups/public): Checksum validation failed, no checksums available from the
 repository -> [Help 2]

I can download the "xbean-server-3.1.0.2-fuse.pom" file with any http client so where is the problem? Is it a problem with Nexus or somewhere else?

Regards,
Mikolaj Menke


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]