Eclipse is running in a JRE, but a JDK is required

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Eclipse is running in a JRE, but a JDK is required

nani2ratna
Hi,

In my system i am using java 1.6 and tomcat 5.5
Eclipse version is Ganymede.
I just updated my version with maven plugin.
And i created a small web application project from eclipse.
When i close and open the eclipse i am getting popup with message ----
---------------------------------------------------------------
The Maven Integration requires that Eclipse be running in a JDK, because a number of Maven core plugins are using jars from the JDk.

Please make sure the -vm option in eclipse.ini is pointing to a JDK and verify that
Installed JRE's are also using JDK installs.
---------------------------------------------------------------------------

After i clicking OK for that in console i am getting error message like this

09/03/02 02:16:26: Eclipse is running in a JRE, but a JDK is required
  Some Maven plugins may not work when importing projects or updating source folders.

---------------------------------------------------------------

To solve this i did as they said in this link
http://www.nabble.com/I-installed-m2eclipse-plugin-and-got-this-error-td16251210.html

But i didnt solve my probelm i put a new argument in eclipse.ini

-vm C:\Program Files\Java\jdk1.6.0_01\bin\java.exe

It didnt solve my problem.

Please help to solve this problem.

Thanks and regards
Ratna Sekhar.
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse is running in a JRE, but a JDK is required

Linkan
put something like

-vm
C:\Java\jdk6\bin\javaw.exe

in your eclipse.ini file located in your eclipse install dir.

//Swanthe

nani2ratna wrote:

> Hi,
>
> In my system i am using java 1.6 and tomcat 5.5
> Eclipse version is Ganymede.
> I just updated my version with maven plugin.
> And i created a small web application project from eclipse.
> When i close and open the eclipse i am getting popup with message ----
> ---------------------------------------------------------------
> The Maven Integration requires that Eclipse be running in a JDK, because a
> number of Maven core plugins are using jars from the JDk.
>
> Please make sure the -vm option in eclipse.ini is pointing to a JDK and
> verify that
> Installed JRE's are also using JDK installs.
> ---------------------------------------------------------------------------
>
> After i clicking OK for that in console i am getting error message like this
>
> 09/03/02 02:16:26: Eclipse is running in a JRE, but a JDK is required
>   Some Maven plugins may not work when importing projects or updating source
> folders.
>
> ---------------------------------------------------------------
>
> To solve this i did as they said in this link
> http://www.nabble.com/I-installed-m2eclipse-plugin-and-got-this-error-td16251210.html
>
> But i didnt solve my probelm i put a new argument in eclipse.ini
>
> -vm C:\Program Files\Java\jdk1.6.0_01\bin\java.exe
>
> It didnt solve my problem.
>
> Please help to solve this problem.
>
> Thanks and regards
> Ratna Sekhar.
>  



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Eclipse is running in a JRE, but a JDK is required

nani2ratna
Hi Thanks for you reply,

I put like this
-vm C:\Java\jdk6\bin\java.exe

and like this tooo
-vm "C:\Java\jdk6\bin\java.exe"

It didnt work.

Then I put like you said like
-vm
C:\Java\jdk6\bin\java.exe

Then its working fine.

Thank you very much
Bye


Linkan wrote
put something like

-vm
C:\Java\jdk6\bin\javaw.exe

in your eclipse.ini file located in your eclipse install dir.

//Swanthe

nani2ratna wrote:
> Hi,
>
> In my system i am using java 1.6 and tomcat 5.5
> Eclipse version is Ganymede.
> I just updated my version with maven plugin.
> And i created a small web application project from eclipse.
> When i close and open the eclipse i am getting popup with message ----
> ---------------------------------------------------------------
> The Maven Integration requires that Eclipse be running in a JDK, because a
> number of Maven core plugins are using jars from the JDk.
>
> Please make sure the -vm option in eclipse.ini is pointing to a JDK and
> verify that
> Installed JRE's are also using JDK installs.
> ---------------------------------------------------------------------------
>
> After i clicking OK for that in console i am getting error message like this
>
> 09/03/02 02:16:26: Eclipse is running in a JRE, but a JDK is required
>   Some Maven plugins may not work when importing projects or updating source
> folders.
>
> ---------------------------------------------------------------
>
> To solve this i did as they said in this link
> http://www.nabble.com/I-installed-m2eclipse-plugin-and-got-this-error-td16251210.html
>
> But i didnt solve my probelm i put a new argument in eclipse.ini
>
> -vm C:\Program Files\Java\jdk1.6.0_01\bin\java.exe
>
> It didnt solve my problem.
>
> Please help to solve this problem.
>
> Thanks and regards
> Ratna Sekhar.
>  



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Eclipse is running in a JRE, but a JDK is required

Rusty Wright
The other thing you can do, which I prefer, is to fiddle with the Windows shortcut that starts eclipse.  Right click on the eclipse item wherever it is in your Windows start menu and select Properties, then select the Shortcut tab.  In the Target box use the -vm option and any others you need, with quotes around things with spaces in them.  For example, mine has (this is all one long line):

"C:\Program Files\eclipse-3.4.2\eclipse.exe" -vm "C:\Program Files\Java\jdk1.5.0_17\bin\javaw" -vmargs -Xms256m -Xmx768m -XX:PermSize=256M -XX:MaxPermSize=512M


nani2ratna wrote:

> Hi Thanks for you reply,
>
> I put like this
> -vm C:\Java\jdk6\bin\java.exe
>
> and like this tooo
> -vm "C:\Java\jdk6\bin\java.exe"
>
> It didnt work.
>
> Then I put like you said like
> -vm
> C:\Java\jdk6\bin\java.exe
>
> Then its working fine.
>
> Thank you very much
> Bye
>
>
>
> Linkan wrote:
>> put something like
>>
>> -vm
>> C:\Java\jdk6\bin\javaw.exe
>>
>> in your eclipse.ini file located in your eclipse install dir.
>>
>> //Swanthe
>>
>> nani2ratna wrote:
>>> Hi,
>>>
>>> In my system i am using java 1.6 and tomcat 5.5
>>> Eclipse version is Ganymede.
>>> I just updated my version with maven plugin.
>>> And i created a small web application project from eclipse.
>>> When i close and open the eclipse i am getting popup with message ----
>>> ---------------------------------------------------------------
>>> The Maven Integration requires that Eclipse be running in a JDK, because
>>> a
>>> number of Maven core plugins are using jars from the JDk.
>>>
>>> Please make sure the -vm option in eclipse.ini is pointing to a JDK and
>>> verify that
>>> Installed JRE's are also using JDK installs.
>>> ---------------------------------------------------------------------------
>>>
>>> After i clicking OK for that in console i am getting error message like
>>> this
>>>
>>> 09/03/02 02:16:26: Eclipse is running in a JRE, but a JDK is required
>>>   Some Maven plugins may not work when importing projects or updating
>>> source
>>> folders.
>>>
>>> ---------------------------------------------------------------
>>>
>>> To solve this i did as they said in this link
>>> http://www.nabble.com/I-installed-m2eclipse-plugin-and-got-this-error-td16251210.html
>>>
>>> But i didnt solve my probelm i put a new argument in eclipse.ini
>>>
>>> -vm C:\Program Files\Java\jdk1.6.0_01\bin\java.exe
>>>
>>> It didnt solve my problem.
>>>
>>> Please help to solve this problem.
>>>
>>> Thanks and regards
>>> Ratna Sekhar.
>>>  
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>     http://xircles.codehaus.org/manage_email
>>
>>
>>
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Eclipse is running in a JRE, but a JDK is required

grjustin
In reply to this post by nani2ratna
Since there is a space in the path you could use the windows short form. use javaw if you do not want the command window.

-vm
C:\Progra~1\Java\jdk6\bin\javaw.exe

Thanks,
Justin

nani2ratna wrote
Hi,

In my system i am using java 1.6 and tomcat 5.5
Eclipse version is Ganymede.
I just updated my version with maven plugin.
And i created a small web application project from eclipse.
When i close and open the eclipse i am getting popup with message ----
---------------------------------------------------------------
The Maven Integration requires that Eclipse be running in a JDK, because a number of Maven core plugins are using jars from the JDk.

Please make sure the -vm option in eclipse.ini is pointing to a JDK and verify that
Installed JRE's are also using JDK installs.
---------------------------------------------------------------------------

After i clicking OK for that in console i am getting error message like this

09/03/02 02:16:26: Eclipse is running in a JRE, but a JDK is required
  Some Maven plugins may not work when importing projects or updating source folders.

---------------------------------------------------------------

To solve this i did as they said in this link
http://www.nabble.com/I-installed-m2eclipse-plugin-and-got-this-error-td16251210.html

But i didnt solve my probelm i put a new argument in eclipse.ini

-vm C:\Program Files\Java\jdk1.6.0_01\bin\java.exe

It didnt solve my problem.

Please help to solve this problem.

Thanks and regards
Ratna Sekhar.
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse is running in a JRE, but a JDK is required

anadikumar
This post has NOT been accepted by the mailing list yet.
In reply to this post by nani2ratna
G:\study\eclipse-jee-galileo-SR2-win32\eclipse\eclipse.exe -vm "E:\Program Files\Java\jdk1.6.0_23\bin\javaw.exe" This works fine. :) Regards, Anadi KUMAR Architecture and R2ds, Channels and Framework, Software Engineer | HSBC Technology and Services - Global Technology HSBC Software Development (India)Limited GLT 4.0 - Panchshil Tech. Park, Block D, S.No. 19, Hissa 2A/11/2, Yerawada, Pune, 411006. India. Mobile. +91 9822622054 Email. anadikumar@hsbc.co.in Email. anadikumar@gmail.com
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse is running in a JRE, but a JDK is required

anadikumar
This post has NOT been accepted by the mailing list yet.
G:\study\eclipse-jee-galileo-SR2-win32\eclipse\eclipse.exe -vm "E:\Program Files\Java\jdk1.6.0_23\bin\javaw.exe"

This works fine. :)

Regards,
Anadi KUMAR
Architecture and R2ds, Channels and Framework, Software Engineer | HSBC Technology and Services - Global Technology
HSBC Software Development (India)Limited
GLT 4.0 - Panchshil Tech. Park, Block D, S.No. 19, Hissa 2A/11/2, Yerawada, Pune, 411006.
India.

Mobile. +91 9822622054
Email. anadikumar@hsbc.co.in
Email. anadikumar@gmail.com
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse is running in a JRE, but a JDK is required

ani786
This post has NOT been accepted by the mailing list yet.
it matters where u add the line too cannot add it at any place add just like this somewhere ....
add somehwer like this

--launcher.defaultAction
openFile


-vm
C:\Progra~1\Java\jdk1.6.0\bin\javaw.exe


--launcher.XXMaxPermSize
512M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse is running in a JRE, but a JDK is required

SkyFairy2
This post has NOT been accepted by the mailing list yet.
In reply to this post by nani2ratna
การใช้งานนั้นโดยแต่เสริมแบตเตอรี่ และ หลอดนิโคตินเหลว (Cartridge) เข้ากับตัวเครื่อง คุณก็สามารถเริ่มการสูบได้แล้ว หากไฟสีแดงอ่อนหรือไม่ติดแสดงว่าคุณต้องชาร์จแบตเตอรี่ หากเมื่อสูบแล้วไม่มีควันคุณต้องเปลี่ยนหรือเติมหลอดบรรจุนิโคตินเหลว joyetech สาร PG ที่ว่านี้เป็นสารที่ใช้เป็นตัวทำละลายระดับ Food-Grade ให้แก่สารตัวอื่นทั้งหมด ให้สามาราถอยู่รวมตัวกันได้ กันการตกตะกอนเมื่อทิ้งไว้นานๆ  PG เป็นสารที่อยู่ในเครื่องสำอางค์แทบทุกชนิด รวมทั้งแชมพู สบู่ โฟมล้างหน้า หรือแม้กระทั่งลูกอม ก็มีสารที่ว่านี้เช่นกัน elips c  หลอดลม. หลอดอาหาร บุหรี่  ถ้าผมสูบบุหรี่ไฟฟ้าอีก 20 ปี แล้วผมไม่เป็นมะเร็งถือว่าผมได้ผลประโยชน์ แต่ถ้าผมเป็นมะเร็ง บุหรี่ไฟฟ้า ไนโตรเจนไดออกไซด์ ก๊าซพิษทำลายเยื่อบุหลอดลมส่วนปลาย และถุงลม ทำให้ผนังถุงลมบางโป่งพอง ถุงลมเล็กๆ หลายอันแตก รวมกันเป็นถุงลมใหญ่ ทำให้เกิดโรคถุงลมโป่งพอง อีกทั้งยังมีผู้ให้บริการหลากแบบเพื่อรอ ให้คำแนะนำท่าน ในพท.ทั่วกรุงเทพ และทั่วทุกภาค eroll สำหรับขั้นตอนการเลิกบุหรี่ด้วยบุหรี่ไฟฟ้า ผมนำมาจากเอกสารกำกับสินค้า