Eclipse cant find peer module

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Eclipse cant find peer module

wuntee
This has happened multiple times, and I have no idea what is happening.  I have a main project of:

com.cable.wuntee.neto.nse-taac

having modules of:

    taac-web
    taac-backend-api
    taac-scheduler

but for some reason taac-web can not find taac-backend-api.  This is the error - can anyone explain what is going on?  Thanks.


    6/3/10 4:45:34 PM MDT: Build errors for taac-web; org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project taac-web: Unable to get dependency information for com.cable.wuntee.neto.nse:taac-backend-api:jar:1.0-SNAPSHOT: Failed to process POM for com.cable.wuntee.neto.nse:taac-backend-api:jar:1.0-SNAPSHOT: Non-resolvable parent POM com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:1.0-SNAPSHOT for com.cable.wuntee.neto.nse:taac-backend-api:1.0-SNAPSHOT: Failed to resolve POM for com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:1.0-SNAPSHOT due to Missing:
    ----------
    1) com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:pom:1.0-SNAPSHOT
    ----------
    1 required artifact is missing.
   
    for artifact:
      com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:pom:1.0-SNAPSHOT
Reply | Threaded
Open this post in threaded view
|

Re: Eclipse cant find peer module

Jason van Zyl-2
Usually it's a version mismatch. In order for workspace resolution to work correctly the versions must match exactly between peer modules.

That, or you've disable workspace resolution by mistake.

On Jun 4, 2010, at 10:32 AM, mrowley wrote:


This has happened multiple times, and I have no idea what is happening.  I
have a main project of:

com.cable.wuntee.neto.nse-taac

having modules of:

   taac-web
   taac-backend-api
   taac-scheduler

but for some reason taac-web can not find taac-backend-api.  This is the
error - can anyone explain what is going on?  Thanks.


   6/3/10 4:45:34 PM MDT: Build errors for taac-web;
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute
goal on project taac-web: Unable to get dependency information for
com.cable.wuntee.neto.nse:taac-backend-api:jar:1.0-SNAPSHOT: Failed to
process POM for com.cable.wuntee.neto.nse:taac-backend-api:jar:1.0-SNAPSHOT:
Non-resolvable parent POM
com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:1.0-SNAPSHOT for
com.cable.wuntee.neto.nse:taac-backend-api:1.0-SNAPSHOT: Failed to resolve
POM for com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:1.0-SNAPSHOT due to
Missing:
   ----------
   1) com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:pom:1.0-SNAPSHOT
   ----------
   1 required artifact is missing.

   for artifact:
     com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:pom:1.0-SNAPSHOT
--
View this message in context: http://old.nabble.com/Eclipse-cant-find-peer-module-tp28780741p28780741.html
Sent from the Maven Eclipse - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Thanks,

Jason

----------------------------------------------------------
Jason van Zyl
Founder,  Apache Maven
http://twitter.com/jvanzyl
---------------------------------------------------------

You are never dedicated to something you have complete confidence in.
No one is fanatically shouting that the sun is going to rise tomorrow.
They know it is going to rise tomorrow. When people are fanatically
dedicated to political or religious faiths or any other kind of 
dogmas or goals, it's always because these dogmas or
goals are in doubt.

  -- Robert Pirzig, Zen and the Art of Motorcycle Maintenance



Reply | Threaded
Open this post in threaded view
|

Re: Eclipse cant find peer module

wuntee
See, the thing is, it was working until I did 'update project configuration' on taac-web.  I have had to do that multiple times due to dependancies not working correctly.

All versions are exactly the same - just double checked '1.0-SNAPSHOT'

I can see that workspace resolution is enabled on all of the projects.

Is there any way to see debug messages? This has happened before, and the only fix was to delete all projects, then re-import them.  



jvanzyl wrote
Usually it's a version mismatch. In order for workspace resolution to work correctly the versions must match exactly between peer modules.

That, or you've disable workspace resolution by mistake.

On Jun 4, 2010, at 10:32 AM, mrowley wrote:

>
> This has happened multiple times, and I have no idea what is happening.  I
> have a main project of:
>
> com.cable.wuntee.neto.nse-taac
>
> having modules of:
>
>    taac-web
>    taac-backend-api
>    taac-scheduler
>
> but for some reason taac-web can not find taac-backend-api.  This is the
> error - can anyone explain what is going on?  Thanks.
>
>
>    6/3/10 4:45:34 PM MDT: Build errors for taac-web;
> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute
> goal on project taac-web: Unable to get dependency information for
> com.cable.wuntee.neto.nse:taac-backend-api:jar:1.0-SNAPSHOT: Failed to
> process POM for com.cable.wuntee.neto.nse:taac-backend-api:jar:1.0-SNAPSHOT:
> Non-resolvable parent POM
> com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:1.0-SNAPSHOT for
> com.cable.wuntee.neto.nse:taac-backend-api:1.0-SNAPSHOT: Failed to resolve
> POM for com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:1.0-SNAPSHOT due to
> Missing:
>    ----------
>    1) com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:pom:1.0-SNAPSHOT
>    ----------
>    1 required artifact is missing.
>
>    for artifact:
>      com.cable.wuntee.neto.nse:wuntee.neto.nse-taac:pom:1.0-SNAPSHOT
> --
> View this message in context: http://old.nabble.com/Eclipse-cant-find-peer-module-tp28780741p28780741.html
> Sent from the Maven Eclipse - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>

Thanks,

Jason

----------------------------------------------------------
Jason van Zyl
Founder,  Apache Maven
http://twitter.com/jvanzyl
---------------------------------------------------------

You are never dedicated to something you have complete confidence in.
No one is fanatically shouting that the sun is going to rise tomorrow.
They know it is going to rise tomorrow. When people are fanatically
dedicated to political or religious faiths or any other kind of
dogmas or goals, it's always because these dogmas or
goals are in doubt.

  -- Robert Pirzig, Zen and the Art of Motorcycle Maintenance


Reply | Threaded
Open this post in threaded view
|

Re: Eclipse cant find peer module

wuntee
This post has NOT been accepted by the mailing list yet.
In reply to this post by Jason van Zyl-2
Is there any way to get a detailed debug output to figure out what is going on? I am still having this issue, but the project will build/install file from the root projecte director (in eclipse, as well as via command line).  I am getting really frustrated having to deploy the war locally every time I need to test... Any help would be great - thanks.