EJB RMIC with Maven and WSAD

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

EJB RMIC with Maven and WSAD

Jake-8
Ok, this is truly driving me mad... Here's the
situation (NOTE: None of the following is in my sphere
of control besides Maven):

Application:
J2EE app with JAR, EJB, and WAR projects

Development Environment:
WSAD 5.1.2

Development Test Environment:
WTE

Build Tool:
Maven 1.0.2

Here's my problem - In order to have the CI build
consistent with the local developer builds I don't
want two different build processes, meaning I want the
same goals, etc... It's working beautifully for every
project except, of course, the EJB project.

I don't want to use WSAD's RMIC generation as that
would make it a different process from CI (that and I
believe that the deploy code that is generated by WSAD
is versioned, making CVS maintenance a nightmare).

I am using the was5 plugin to do the generation on the
CI machine, and that works great. However, since the
developer machines don't have a full instance of WAS,
the plugin (or specifically the ant task it uses)
blows up... Here is a snippet of the error:

    [wasEjbDeploy] Failure invoking BootLoader.startup
method
    [wasEjbDeploy]
java.lang.reflect.InvocationTargetException
    [wasEjbDeploy]      at
sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
    [wasEjbDeploy]      at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)
    [wasEjbDeploy]      at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:41)
    [wasEjbDeploy]      at
java.lang.reflect.Method.invoke(Method.java:386)
    [wasEjbDeploy]      at
com.ibm.etools.ejbdeploy.batch.impl.BootLoaderLoader.startup(BootLoaderLoader.java:315)
    [wasEjbDeploy]      at
com.ibm.etools.ejbdeploy.batch.impl.BatchDeploy.startup(BatchDeploy.java:207)
    [wasEjbDeploy]      at
com.ibm.etools.ejbdeploy.EJBDeploy.startup(EJBDeploy.java:382)
    [wasEjbDeploy]      at
com.ibm.etools.ejbdeploy.EJBDeploy.execute(EJBDeploy.java:77)
    [wasEjbDeploy]      at
com.ibm.etools.ejbdeploy.EJBDeploy.main(EJBDeploy.java:307)
    [wasEjbDeploy] Caused by:
java.lang.RuntimeException: Fatal Error: Unable to
locate matching org.eclipse.core.runtime plug-in.

Yes, was5.home is set and it finds the ant tasks just
fine...

Any help on this would be greatly appreciated!


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]