Doxia-Core in the latest version and Confluence format

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Doxia-Core in the latest version and Confluence format

Kornel Skałkowski
Hi,

i use doxia maven plugin to generate a site from files in the
Confluence format. The latest version of the doxia-module-confluence
is 1.1-SNAPSHOT (which can be reached from
https://svn.apache.org/repos/asf/maven/doxia/doxia/trunk/doxia-modules/doxia-module-confluence/
repository). But i'm a little confused because if i want use this
version of confluence module i have to use the doxia-core artifact in
1.0-alpha-11 version, what means that my pom.xml file should contains
following content:

    <plugins>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-site-plugin</artifactId>
      </plugin>
          <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-site-plugin</artifactId>
                <version>2.0-beta-7</version>
                <dependencies>
                        <dependency>
                                <groupId>org.apache.maven.doxia</groupId>
                                <artifactId>doxia-core</artifactId>
                                <version>1.0-alpha-11</version>
                        </dependency>
                        <dependency>
                                <groupId>org.apache.maven.doxia</groupId>
                                <artifactId>doxia-module-confluence</artifactId>
                                <version>1.1-SNAPSHOT</version>
                        </dependency>
                </dependencies>
          </plugin>
    </plugins>

If in above content i change doxia-core version on newer (for example
1.1-SNAPSHOT) i always get the following error:

[FATAL ERROR] org.apache.maven.plugins.site.SiteMojo#execute() caused a linkage
error (java.lang.NoSuchMethodError) and may be out-of-date. Check the realms:
[FATAL ERROR] Plugin realm = app0.child-container[org.apache.maven.plugins:maven
-site-plugin]
urls[0] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
/plugins/maven-site-plugin/2.0-beta-7/maven-site-plugin-2.0-beta-7.jar
urls[1] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
/doxia/doxia-core/1.1-SNAPSHOT/doxia-core-1.1-SNAPSHOT.jar
urls[2] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
/doxia/doxia-logging-api/1.1-SNAPSHOT/doxia-logging-api-1.1-SNAPSHOT.jar
urls[3] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/codehaus/ple
xus/plexus-utils/1.5.1/plexus-utils-1.5.1.jar
urls[4] = file:/C:/Documents and Settings/Kornel/.m2/repository/xerces/xercesImp
l/2.8.1/xercesImpl-2.8.1.jar
urls[5] = file:/C:/Documents and Settings/Kornel/.m2/repository/xml-apis/xml-api
s/1.3.03/xml-apis-1.3.03.jar
urls[6] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
/doxia/doxia-module-confluence/1.0-beta-1-AGH-SNAPSHOT/doxia-module-confluence-1
.0-beta-1-AGH-SNAPSHOT.jar
urls[7] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
/doxia/doxia-module-xhtml/1.0-alpha-11/doxia-module-xhtml-1.0-alpha-11.jar
urls[8] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
/doxia/doxia-decoration-model/1.0-alpha-11/doxia-decoration-model-1.0-alpha-11.j
ar

So is any way to configure maven-site-plugin in order to use the
latest version of doxia-core module???

Best regards,
Kornel Skałkowski
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Doxia-Core in the latest version and Confluence format

Lukas Theussl-4
Unfortunately this is not possible. All published versions of maven include an
alpha version of doxia in their uber-jar, see
http://jira.codehaus.org/browse/MNG-3402 . You cannot therefore mix in some
1.1-SNAPSHOT dependencies as you will get all sort of class loading/linkage
errors. So your choice is to wait until Doxia-1.1 has been released (and maven
updated to use it), or try to build it yourself with updated deps (I can try to
put together some docs for that if people are interested).

HTH,
-Lukas


Kornel Skałkowski wrote:

> Hi,
>
> i use doxia maven plugin to generate a site from files in the
> Confluence format. The latest version of the doxia-module-confluence
> is 1.1-SNAPSHOT (which can be reached from
> https://svn.apache.org/repos/asf/maven/doxia/doxia/trunk/doxia-modules/doxia-module-confluence/
> repository). But i'm a little confused because if i want use this
> version of confluence module i have to use the doxia-core artifact in
> 1.0-alpha-11 version, what means that my pom.xml file should contains
> following content:
>
>     <plugins>
>       <plugin>
>         <groupId>org.apache.maven.plugins</groupId>
>         <artifactId>maven-site-plugin</artifactId>
>       </plugin>
>  <plugin>
> <groupId>org.apache.maven.plugins</groupId>
> <artifactId>maven-site-plugin</artifactId>
> <version>2.0-beta-7</version>
> <dependencies>
> <dependency>
> <groupId>org.apache.maven.doxia</groupId>
> <artifactId>doxia-core</artifactId>
> <version>1.0-alpha-11</version>
> </dependency>
> <dependency>
> <groupId>org.apache.maven.doxia</groupId>
> <artifactId>doxia-module-confluence</artifactId>
> <version>1.1-SNAPSHOT</version>
> </dependency>
> </dependencies>
>  </plugin>
>     </plugins>
>
> If in above content i change doxia-core version on newer (for example
> 1.1-SNAPSHOT) i always get the following error:
>
> [FATAL ERROR] org.apache.maven.plugins.site.SiteMojo#execute() caused a linkage
> error (java.lang.NoSuchMethodError) and may be out-of-date. Check the realms:
> [FATAL ERROR] Plugin realm = app0.child-container[org.apache.maven.plugins:maven
> -site-plugin]
> urls[0] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
> /plugins/maven-site-plugin/2.0-beta-7/maven-site-plugin-2.0-beta-7.jar
> urls[1] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
> /doxia/doxia-core/1.1-SNAPSHOT/doxia-core-1.1-SNAPSHOT.jar
> urls[2] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
> /doxia/doxia-logging-api/1.1-SNAPSHOT/doxia-logging-api-1.1-SNAPSHOT.jar
> urls[3] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/codehaus/ple
> xus/plexus-utils/1.5.1/plexus-utils-1.5.1.jar
> urls[4] = file:/C:/Documents and Settings/Kornel/.m2/repository/xerces/xercesImp
> l/2.8.1/xercesImpl-2.8.1.jar
> urls[5] = file:/C:/Documents and Settings/Kornel/.m2/repository/xml-apis/xml-api
> s/1.3.03/xml-apis-1.3.03.jar
> urls[6] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
> /doxia/doxia-module-confluence/1.0-beta-1-AGH-SNAPSHOT/doxia-module-confluence-1
> .0-beta-1-AGH-SNAPSHOT.jar
> urls[7] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
> /doxia/doxia-module-xhtml/1.0-alpha-11/doxia-module-xhtml-1.0-alpha-11.jar
> urls[8] = file:/C:/Documents and Settings/Kornel/.m2/repository/org/apache/maven
> /doxia/doxia-decoration-model/1.0-alpha-11/doxia-decoration-model-1.0-alpha-11.j
> ar
>
> So is any way to configure maven-site-plugin in order to use the
> latest version of doxia-core module???
>
> Best regards,
> Kornel Skałkowski
Loading...