Doxia 1.7.4 Site tools fails on Java 9

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Doxia 1.7.4 Site tools fails on Java 9

karianna
Hi all,

Doxia site-tools uses an old apache commons lib (which is fixed in
1.7.5-SNAPSHOT), any chance of a release of the site-tools (and
consequently) site plugin to support Java 9?

Cheers,
Martijn
Reply | Threaded
Open this post in threaded view
|

Re: Doxia 1.7.4 Site tools fails on Java 9

Enrico Olivelli
which is the broken dependency ?
maybe you could override the dependency of the plugin directly in your pom
so you won't be stopped ?

-- Enrico

2017-09-26 12:59 GMT+02:00 Martijn Verburg <[hidden email]>:

> Hi all,
>
> Doxia site-tools uses an old apache commons lib (which is fixed in
> 1.7.5-SNAPSHOT), any chance of a release of the site-tools (and
> consequently) site plugin to support Java 9?
>
> Cheers,
> Martijn
>
Reply | Threaded
Open this post in threaded view
|

Re: Doxia 1.7.4 Site tools fails on Java 9

rfscholte
@Enrico, commons-lang2 must be replaced with commons-lang3, which includes  
code changes due to the new package structure.

@Martijn, indeed, let's do a release.

thanks,
Robert

On Tue, 26 Sep 2017 14:07:31 +0200, Enrico Olivelli <[hidden email]>  
wrote:

> which is the broken dependency ?
> maybe you could override the dependency of the plugin directly in your  
> pom
> so you won't be stopped ?
>
> -- Enrico
>
> 2017-09-26 12:59 GMT+02:00 Martijn Verburg <[hidden email]>:
>
>> Hi all,
>>
>> Doxia site-tools uses an old apache commons lib (which is fixed in
>> 1.7.5-SNAPSHOT), any chance of a release of the site-tools (and
>> consequently) site plugin to support Java 9?
>>
>> Cheers,
>> Martijn

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]