Does maven-filtering really require maven-shared-utils 3.3.0-SNAPSHOT?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Does maven-filtering really require maven-shared-utils 3.3.0-SNAPSHOT?

Dennis Lundberg-2
Hi,

I'm checking the scope of releasing maven-resources-plugin. There is
currently a transitive dependency chain like this:
- maven-resources-plugin depends upon
- maven-filtering 3.2.0-SNAPSHOT depends upon
- maven-shared-utils 3.3.0-SNAPSHOT

That last SNAPSHOT was added in
https://github.com/apache/maven-filtering/commit/17fe0c18929be13fb75b00d76628dc7146f85aec
but it does not seem related to the commit message or the other changes in
the commit. So I'm curious, does maven-filtering really need the latest
version of maven-shared-utils? The build with tests succeeds if I turn it
back to the latest stable version 3.2.1.

Note that there is also a pending pull request that does away with many,
but not all,  usages of maven-shared-utils classes in maven-filtering. I'd
like for that to be merged and included in the upcoming releases.
https://github.com/apache/maven-filtering/pull/13

--
Dennis Lundberg