Cutting Checkstyle 3.1.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Cutting Checkstyle 3.1.1

Enrico Olivelli
Hi folks,
We should release checkstyle plugin in order to have a version of the
plugin compatible to the latest version of checkstyle (8.29).

There are security issues that are flagging old Checkstyle versions,
and I have noticed the github bot started to flag our plugin and
suggest an upgrade of checkstyle dependency but actually
maven-checkstyle-plugin 3.1.0 is not compatible with 8.29.

Master branch is in good shape.
I am going to cut a release soon.


If you have objections please let me know

Regards
Enrico

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Cutting Checkstyle 3.1.1

Elliotte Rusty Harold
From that bug it looks like the incompatibilities might be more subtle
than a complete breakage. That is, they might only surface with some
configurations and not with others.

On Thu, Feb 6, 2020 at 9:52 AM Enrico Olivelli <[hidden email]> wrote:

>
> Elliotte,
> if you did not have problems then we don't have to hurry.
> I was convinced that 3.1.0 was not compatible with 8.29,
>
> see
> https://issues.apache.org/jira/browse/MCHECKSTYLE-384
>
> btw we can cut the release, there is enough stuff to make a release
> we are working together with Checkstyle community and I feel it is a
> good step forward to let them move forward with changes in Checkstyle
>
> Enrico
>
> Il giorno gio 6 feb 2020 alle ore 15:41 Elliotte Rusty Harold
> <[hidden email]> ha scritto:
> >
> > On Thu, Feb 6, 2020 at 9:33 AM Enrico Olivelli <[hidden email]> wrote:
> > >
> > > Hi folks,
> > > We should release checkstyle plugin in order to have a version of the
> > > plugin compatible to the latest version of checkstyle (8.29).
> > >
> > > There are security issues that are flagging old Checkstyle versions,
> > > and I have noticed the github bot started to flag our plugin and
> > > suggest an upgrade of checkstyle dependency but actually
> > > maven-checkstyle-plugin 3.1.0 is not compatible with 8.29.
> > >
> >
> > No objection to a release, but I'm surprised they're not compatible. I
> > updated one of my projects yesterday to 3.1.0/8.29 and didn't notice
> > any issues:
> >
> > https://github.com/GoogleCloudPlatform/appengine-plugins-core/pull/830/files
> >
> >
> > --
> > Elliotte Rusty Harold
> > [hidden email]
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


--
Elliotte Rusty Harold
[hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]