[Created] (MNG-7106) VersionRange produces a version range that is incompatible with itself

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Created] (MNG-7106) VersionRange produces a version range that is incompatible with itself

Tibor Digana (Jira)
Akshay Shankara created MNG-7106:
------------------------------------

             Summary: VersionRange produces a version range that is incompatible with itself
                 Key: MNG-7106
                 URL: https://issues.apache.org/jira/browse/MNG-7106
             Project: Maven
          Issue Type: Bug
    Affects Versions: 3.6.3
            Reporter: Akshay Shankara


When a hard version requirement (Ex - [1.0]) is passed to [VersionRange#createFromVersionSpec(String)|https://github.com/apache/maven/blob/maven-3.6.3/maven-artifact/src/main/java/org/apache/maven/artifact/versioning/VersionRange.java#L106], it is parsed to [1.0, 1.0]. But, this version range is invalid [according to this exception|https://github.com/apache/maven/blob/maven-3.6.3/maven-artifact/src/main/java/org/apache/maven/artifact/versioning/VersionRange.java#L214-L217]. If the parsed version range ([1.0, 1.0]) is converted to a String, it cannot be parsed once again by VersionRange#createFromVersionSpec(String).

Steps to reproduce -
{code:java}
VersionRange versionRange = VersionRange.createFromVersionSpec("[1.0]"); // [1.0, 1.0]
String stringVersionRange = VersionRange.toString(versionRange); // "[1.0, 1.0]"
VersionRange exceptionVersionRange = VersionRange.createFromVersionSpec(stringVersionRange); // <- InvalidVersionSpecificationException( "Range cannot have identical boundaries: [1.0, 1.0]" )
{code}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)