[Commented] (MNG-6983) Plugin not executed when using pluginManagement and variable in groupId

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Commented] (MNG-6983) Plugin not executed when using pluginManagement and variable in groupId

Jack Leech (Jira)

    [ https://issues.apache.org/jira/browse/MNG-6983?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17196179#comment-17196179 ]

Paul Pazderski commented on MNG-6983:
-------------------------------------

No comments? Whatever you think of the possible fix I would appreciate a comment on the failing example I attached.

After I noticed it worked in 3.6.2 I bisect the issue and came to [3a80ae08aac785deb61e417f82560cb06209d5bc|https://gitbox.apache.org/repos/asf?p=maven.git;a=commit;h=3a80ae08aac785deb61e417f82560cb06209d5bc] as causing commit. Apparently there is a difference between {{StringSearchModelInterpolator}} and {{StringVisitorModelInterpolator}} which make this example fail.

> Plugin not executed when using pluginManagement and variable in groupId
> -----------------------------------------------------------------------
>
>                 Key: MNG-6983
>                 URL: https://issues.apache.org/jira/browse/MNG-6983
>             Project: Maven
>          Issue Type: Bug
>          Components: core, Plugins and Lifecycle
>    Affects Versions: 3.6.3
>            Reporter: Paul Pazderski
>            Priority: Major
>         Attachments: pluginNotExecuted.zip
>
>
> I have a project build with maven where some maven plugins are not executed without any warning or error shown in output.
> I was could reproduce the issue with a minimal example. (see attachment)
> The expected result of this example is to get the one source file compiled if you invoke {{mvn compile}}.
> If I run this example using Maven 3.6.3 the following output appears:
> {noformat}
> [INFO] Scanning for projects...
> [INFO]
> [INFO] -------------------------< org.example:child >--------------------------
> [INFO] Building child 0.0.1-SNAPSHOT
> [INFO] --------------------------------[ jar ]---------------------------------
> [INFO]
> [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ child ---
> [INFO] Using 'UTF-8' encoding to copy filtered resources.
> [INFO] skip non existing resourceDirectory [...]\pluginNotExecuted\src\main\resources
> [INFO]
> [INFO] --- maven-compiler-plugin:3.1:compile (default-compile) @ child ---
> [INFO] No sources to compile
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD SUCCESS
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time:  0.644 s
> [INFO] Finished at: [...]
> [INFO] ------------------------------------------------------------------------
> {noformat}
> Notice that there is no execution of the build-helper-maven-plugin (and as consequence no source compiled) and no indication why it is missing.
> From what I've found the problem seem to be the usage of variable in the plugins groupId. If you replace either the variable in parent- or child-pom with the actual value the build shows a warning
> {noformat}
> [WARNING]
> [WARNING] Some problems were encountered while building the effective model for org.example:child:jar:0.0.1-SNAPSHOT
> [WARNING] 'build.plugins.plugin.version' for org.codehaus.mojo:build-helper-maven-plugin is missing. @ line 16, column 21
> [WARNING]
> [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
> [WARNING]
> [WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
> [WARNING]
> {noformat}
> If you replace both variables with the actual value everything works as expected.
>  
> I investigated the problem further and will provide more details with a pull request for a possible fix.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)