[Commented] (MDEPLOY-254) Maven Deploy Plugin deploy jar twice : Maven 3.3.3

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Commented] (MDEPLOY-254) Maven Deploy Plugin deploy jar twice : Maven 3.3.3

Scof (Jira)

    [ https://issues.apache.org/jira/browse/MDEPLOY-254?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17317004#comment-17317004 ]

Alexander Kriegisch commented on MDEPLOY-254:
---------------------------------------------

Thanks, [~mthmulders], I found a [4.0.0-alpha-1 distribution|https://repository.apache.org/content/repositories/snapshots/org/apache/maven/apache-maven/4.0.0-alpha-1-SNAPSHOT/apache-maven-4.0.0-alpha-1-20210405.175456-88-bin.zip] and used it for testing.

{quote}Does this still happen with Maven master?{quote}

[~michael-o], it does not happen in master. I tried without {{<attach>false</attach>}} and it worked. Maven Install only tries to install the source JAR once, hence deployment also works as expected. Unfortunately, it is not an option for me to build with an alpha version, I just wanted to provide feedback. I think it would be nice to port the fix back to a maintenance version 3.6.4. Is that going to happen? Waiting for the 4.0.0 release might still take a long time and not every developer will upgrade quickly upon availability just for solving this problem.

> Maven Deploy Plugin deploy jar twice : Maven 3.3.3
> --------------------------------------------------
>
>                 Key: MDEPLOY-254
>                 URL: https://issues.apache.org/jira/browse/MDEPLOY-254
>             Project: Maven Deploy Plugin
>          Issue Type: Bug
>            Reporter: Akshay
>            Assignee: Karl Heinz Marbaise
>            Priority: Blocker
>             Fix For: waiting-for-feedback, wontfix-candidate
>
>         Attachments: log1-mvn_clean_deploy_-Ptwice-source-jar-goal.txt, log2-mvn_clean_deploy_-Psource-and-shade-plugin.txt, sample-project.zip
>
>
> Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy (default-deploy) on project ****** :
> Failed to retrieve remote metadata ******/maven-metadata.xml:
> Could not transfer metadata ****** from/to ****** 
> {color:#FF0000} Not authorized , ReasonPhrase:Unauthorized. {color}
>  
> Wanted to know if the fix is out in a later version of Maven?



--
This message was sent by Atlassian Jira
(v8.3.4#803005)