[Commented] (MASSEMBLY-864) Dependencies specified in activeByDefault profile not picked up.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Commented] (MASSEMBLY-864) Dependencies specified in activeByDefault profile not picked up.

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/MASSEMBLY-864?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16088951#comment-16088951 ]

Plamen Totev commented on MASSEMBLY-864:
----------------------------------------

I'm glad the workaround is working.

I've look into the issue a bit more and in general the Maven dependency resolution works as expected so for now I don't think there is a need to raise a bug with the core. It's interesting why the assembly plugin does not get the dependencies from {{MavenProject}} instance (for example the compiler plugin does that and it works) but instead uses somewhat more complex solution. So for now it think is better to see if more experienced contributor show some love to the issue.

> Dependencies specified in activeByDefault profile not picked up.
> ----------------------------------------------------------------
>
>                 Key: MASSEMBLY-864
>                 URL: https://issues.apache.org/jira/browse/MASSEMBLY-864
>             Project: Maven Assembly Plugin
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>            Reporter: Axel Fontaine
>
> I have the following dependencySet in my assembly XML:
> <dependencySet>
>     <outputDirectory>jre</outputDirectory>
>     <includes>
>         <include>com.oracle:server-jre</include>
>     </includes>
>     <unpack>true</unpack>
>     <unpackOptions>
>         <includes>
>             <include>jdk8.74/jre/**/*</include>
>         </includes>
>     </unpackOptions>
> </dependencySet>
> And the following dependency in my pom.xml:
> <dependency>
>     <groupId>com.oracle</groupId>
>     <artifactId>server-jre</artifactId>
>     <classifier>linux-x64</classifier>
>     <version>8.74</version>
>     <type>tar.gz</type>
>     <scope>provided</scope>
> </dependency>
> The dependency gets correctly picked up when it is declared within the main dependencies section of the POM. However when it is only present within a profile:
>     <profiles>
>         <profile>
>             <id>CommercialDBTest</id>
>             <activation>
>                 <activeByDefault>true</activeByDefault>
>             </activation>
>             <dependencies>
>                 <dependency>
>                     <groupId>com.oracle</groupId>
>                     <artifactId>server-jre</artifactId>
>                     <classifier>linux-x64</classifier>
>                     <type>tar.gz</type>
>                     <scope>provided</scope>
>                 </dependency>
> I then get
> [WARNING] The following patterns were never triggered in this artifact exclusion filter:
> o  'com.oracle:server-jre'



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)
Loading...