[Closed] (SUREFIRE-1265) reuseForks=false fails on jdk-9-ea builds

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Closed] (SUREFIRE-1265) reuseForks=false fails on jdk-9-ea builds

JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/SUREFIRE-1265?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Tibor Digana closed SUREFIRE-1265.
----------------------------------
    Resolution: Fixed

https://git-wip-us.apache.org/repos/asf?p=maven-surefire.git;a=commit;h=cba4adb1b93002c5b4bb2d2f22f461cc53bd8738

> reuseForks=false fails on jdk-9-ea builds
> -----------------------------------------
>
>                 Key: SUREFIRE-1265
>                 URL: https://issues.apache.org/jira/browse/SUREFIRE-1265
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Maven Surefire Plugin
>    Affects Versions: 2.19.1
>            Reporter: Michael Musgrove
>            Assignee: Tibor Digana
>              Labels: jigsaw
>             Fix For: 2.20.1
>
>         Attachments: j9test.tar
>
>
> When I run any surefire test (with reuseForks=false) that uses java.sql classes on recent jdk-9 ea builds it fails with:
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.19.1:test (default-test) on project maven-surefire-plugin-example: Execution default-test of goal org.apache.maven.plugins:maven-surefire-plugin:2.19.1:test failed: java.lang.NoClassDefFoundError: java/sql/SQLException: java.sql.SQLException -> [Help 1]
> If I run it with reuseForks=true it works fine.
> This problem was introduced in jdk build 9-ea+122 (http://download.java.net/java/jdk9/changes/jdk-9+122.html) when the jigsaw team addressed:
>     d20279be77d9 8154189 Deprivilege java.sql and java.sql.rowset module



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)
Loading...