[Closed] (MPOM-207) Upgrade maven-compiler-plugin to version 3.8.1

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Closed] (MPOM-207) Upgrade maven-compiler-plugin to version 3.8.1

M.P. Korstanje (Jira)

     [ https://issues.apache.org/jira/browse/MPOM-207?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Herve Boutemy closed MPOM-207.
------------------------------
    Resolution: Fixed

done in [b3e55ebbd1f5dc81140243d17379423563eb6767|https://gitbox.apache.org/repos/asf?p=maven-apache-parent.git;a=commit;h=b3e55ebbd1f5dc81140243d17379423563eb6767]

> Upgrade maven-compiler-plugin to version 3.8.1
> ----------------------------------------------
>
>                 Key: MPOM-207
>                 URL: https://issues.apache.org/jira/browse/MPOM-207
>             Project: Maven POMs
>          Issue Type: Dependency upgrade
>          Components: maven
>    Affects Versions: MAVEN-33, ASF-21
>            Reporter: Karl Heinz Marbaise
>            Assignee: Karl Heinz Marbaise
>            Priority: Minor
>             Fix For: ASF-22
>
>
> Release Notes - Maven Compiler Plugin - Version 3.8.0
> h3.  Bug
>  * MCOMPILER-311 - NPE when --patch-module is used
>  * MCOMPILER-321 - Problematic Java 9 modules are silently ignored
>  * MCOMPILER-332 - Java 10 not supported
>  * MCOMPILER-338 - Build Issue based on MCOMPILER-192 IT
>  * MCOMPILER-342 - Unsupported class file major version 55
>  * MCOMPILER-343 - Tests fail to compile in modularized project due to wrong module descriptor path being passed to plexus-java
> h3. Improvement
>  * MCOMPILER-313 - Support mrjar dependency with module descriptor only in META-INF/versions/x
>  * MCOMPILER-323 - Support multi-release jars
>  * MCOMPILER-335 - Update default source/target from 1.5 to 1.6
>  * MCOMPILER-341 - Compile module-info.java files located in test sources
> h3. Task
>  * MCOMPILER-336 - Dependency that should be on modulepath sometime put on classpath
>  * MCOMPILER-344 - Deprecate <optimize> flag
>  * MCOMPILER-350 - Add GitHub Documentation
> h3. Dependency upgrade
>  * MCOMPILER-324 - Upgrade parent to 31
>  * MCOMPILER-351 - Upgrade maven-plugins parent to version 32
>  * MCOMPILER-352 - Upgrade maven-shared-utils to 3.2.1
>  * MCOMPILER-353 - Upgrade plexus-compiler to 2.8.4



--
This message was sent by Atlassian Jira
(v8.3.4#803005)