Artifacts not found

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Artifacts not found

Menke, Mikolaj
Hello,

I am running Nexus 2.6.2 and have some issue with one of the proxied repositories. The repository is https://repository.jboss.org/nexus/content/groups/ea/. When I go to  "Browse Index" tab it shows me completely different artifacts (versions) than these found on the "Browse Remote" tab. When I try to download any of the artifacts from "Browse Index" I get the following error (this is an example):

404 - Not Found
Path /io/fabric8/archetype-builder/1.0.0.redhat-329/archetype-builder-1.0.0.redhat-329.jar not found in local nor in remote storage of M2Repository(id=jboss-ea)

Indeed these artifacts do not exist on the remote repository but they can be found when browsing index on the local Nexus proxied repository. Why is that and what can I do with this? Thank you in advance for your help.

Regards,
Mikolaj Menke


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Artifacts not found

Peter Lynch-2
The index on the remote needs to be updated to reflect what is actually on the remote.

According to https://repository.jboss.org/nexus/content/groups/ea/.index/nexus-maven-repository-index.properties, this has been a while and so is likely out of date.

Normally you would run a Download Indexes task against your proxy to fetch the latest indexes on the remote. But since the remote index is out of date, this may not completely resolve your problem.

BTW just to be clear, out of date indexes do not prevent downloading artifacts.



On Tue, Apr 8, 2014 at 5:27 AM, Menke, Mikolaj <[hidden email]> wrote:
Hello,

I am running Nexus 2.6.2 and have some issue with one of the proxied repositories. The repository is https://repository.jboss.org/nexus/content/groups/ea/. When I go to  "Browse Index" tab it shows me completely different artifacts (versions) than these found on the "Browse Remote" tab. When I try to download any of the artifacts from "Browse Index" I get the following error (this is an example):

404 - Not Found
Path /io/fabric8/archetype-builder/1.0.0.redhat-329/archetype-builder-1.0.0.redhat-329.jar not found in local nor in remote storage of M2Repository(id=jboss-ea)

Indeed these artifacts do not exist on the remote repository but they can be found when browsing index on the local Nexus proxied repository. Why is that and what can I do with this? Thank you in advance for your help.

Regards,
Mikolaj Menke


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]