Quantcast

Apache Maven WAR Plugin Version 3.0.0 Released

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Apache Maven WAR Plugin Version 3.0.0 Released

khmarbaise
The Apache Maven team is pleased to announce the release of the
Apache Maven WAR Plugin, version 3.0.0.

The WAR Plugin is responsible for collecting all artifact dependencies, classes
and resources of the web application and packaging them into a web application
archive.

http://maven.apache.org/plugins/maven-war-plugin/

You should specify the version in your project's plugin configuration:

<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-war-plugin</artifactId>
  <version>3.0.0</version>
</plugin>

You can download the appropriate sources etc. from the download page:

https://maven.apache.org/plugins/maven-war-plugin/download.cgi

Important Note:

 * Maven 3.X only
 * JDK 6 minimum requirement

Release Notes - Maven WAR Plugin - Version 3.0.0

https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12318121&version=12331760

Bugs:

 * [MWAR-367] - Overlay removes /META-INF/context.xml
 * [MWAR-369] - Upgrade to XStream 1.4.9
 * [MWAR-379] - manifest goal violates general Maven principle and creates file into src/main/..

Documentation:

 * [MWAR-346] - Fix broken links

Improvements:

 * [MWAR-225] - Add support for customizing filtering delimiters like the resources plugin
 * [MWAR-262] - <failOnMissingWebXml> default value should be false for Servlet level > 2.5 projects
 * [MWAR-326] - Add LifecycleMapping and ArtifactHandler from maven-core to target packaging plugin
 * [MWAR-328] - Upgrade to Maven 3.0 compatiblity / JDK 6
 * [MWAR-347] - Upgrade plexus-io to 2.6
 * [MWAR-348] - Upgrade maven-invoker-plugin to 1.10
 * [MWAR-349] - Upgrade to fluido skin 1.4.0
 * [MWAR-361] - Removed unused dependencies in project
 * [MWAR-362] - Bump version to 3.0.0-SNAPSHOT
 * [MWAR-363] - Removed hard coded version for maven-invoker-plugin
 * [MWAR-364] - Upgrade plexus-utils to 3.0.22
 * [MWAR-365] - Upgrade plexus-archiver from 3.0.1 to 3.0.3
 * [MWAR-366] - Change package to org.apache.maven.plugins to prevent conflict with Maven Core
 * [MWAR-370] - Upgrade plexus-archiver 3.0.3 to 3.1.1
 * [MWAR-372] - Upgrade maven-archiver to 3.0.1
 * [MWAR-373] - Make finalName readonly parameter
 * [MWAR-376] - Remove param properties that doesn't make sense for CLI usage
 * [MWAR-380] - Filtered resources folder should be changed
 * [MWAR-381] - Upgrade maven-archiver to 3.0.2
 * [MWAR-382] - Upgrade plexus-utils to 3.0.24
 * [MWAR-383] - Upgrade plexus-archiver to 3.2 / commons-io to 2.5
 * [MWAR-385] - Upgrade maven-plugins to version 30
 * [MWAR-387] - Upgrade of 'plexus-archiver' to version 3.3.
 * [MWAR-388] - Upgrade maven-archiver to 3.1.0
 * [MWAR-389] - Upgrade maven-filtering to 3.1.1

New Feature:

 * [MWAR-350] - Add Skip Parameter to Skip the process
Task
 * [MWAR-391] - Upgrade of plexus-archiver to 3.4.
 * [MWAR-392] - Upgrade of plexus-interpolation to 1.22.
 * [MWAR-393] - Upgrade of maven-archiver to 3.1.1.

Enjoy,

-The Apache Maven team

Loading...