Apache Maven JAR Plugin Version 3.0.0 Released

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Apache Maven JAR Plugin Version 3.0.0 Released

khmarbaise
The Apache Maven team is pleased to announce the release of the
Apache Maven JAR Plugin Version 3.0.0.
 
https://maven.apache.org/plugins/maven-jar-plugin/

Important Note:

 * Maven 3.X only
 * JDK 6 minimum requirement

You should specify the version in your project's plugin configuration:
 
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-jar-plugin</artifactId>
  <version>3.0.0</version>
</plugin>

You can download the appropriate sources etc. from the download page:
 
https://maven.apache.org/plugins/maven-jar-plugin/download.cgi
 
Release Notes Maven JAR Plugin 3.0.0

https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12317526&version=12334171

Bugs:

 * [MJAR-177] - Empty string should be treated as default classifier
 * [MJAR-198] - jar:jar without classifier replaces default jar
 * [MJAR-204] - Adding plexus-utils version 3.0.22
 * [MJAR-205] - Compatibility with JDK9 requires an update of plexus-archiver
 * [MJAR-216] - Documentation for skip param in test-jar goal is wrong

Documentation:

 * [MJAR-197] - Typo in site navigation

Improvements:

 * [MJAR-183] - Add LifecycleMapping and ArtifactHandler from maven-core to target packaging plugin
 * [MJAR-194] - Upgrade plexus-archiver to 2.10
 * [MJAR-199] - Option "classifier" to goal test-jar
 * [MJAR-201] - Upgrade Maven 3.X Only JDK 1.6
 * [MJAR-202] - Bump version to 3.0.0-SNAPSHOT
 * [MJAR-203] - Change package to org.apache.maven.plugins to prevent conflict with Maven Core
 * [MJAR-207] - Upgrade plexus-archiver from 3.0.3 to 3.1
 * [MJAR-208] - Make naming of properties consistent
 * [MJAR-209] - Remove param properties that doesn't make sense for CLI usage
 * [MJAR-210] - Remove useDefaultManifestFile parameter
 * [MJAR-214] - Replace @pom.version@ with @project.version@ in Integration Tests
 * [MJAR-215] - Upgrade plexus-archiver from 3.1 to 3.1.1 in synch with maven-archiver 3.0.1
 * [MJAR-217] - Make finalName readonly parameter

Tasks:

 * [MJAR-213] - Upgrade to maven-archiver 3.0.1
 * [MJAR-218] - Upgrade to maven-archiver 3.0.2 to fix regression

Reporters of this Release:

 * Sanne Grinovero [MJAR-205]
 * Leo Breuss [MJAR-199]
 * Elias Elmqvist Wulcan [MJAR-198]
 * Andreas Kohn [MJAR-197]
 * Stefan Fussenegger [MJAR-177]

Tester of this Release:

 * Stian Soiland-Reyes

Many thanks to all reporters/contributors/testers of this release.

Enjos,
 
-The Apache Maven team
Loading...