Quantcast

Apache Maven Compiler Plugin 3.6.0 Released

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Apache Maven Compiler Plugin 3.6.0 Released

Robert Scholte-6
The Apache Maven team is pleased to announce the release of the Apache  
Maven Compiler Plugin, version 3.6.0

The Compiler Plugin is used to compile the sources of your project.

This version introduces support of several new features of Java 9, such as:
   JEP 247: Compile for Older Platform Versions
   JEP 261: Module System

Projects which want to add the module-info and also want to stay  
compatible with Java 8 or earlier versions  should have a look at  
https://maven.apache.org/plugins/maven-compiler-plugin/examples/module-info.html

https://maven.apache.org/plugins/maven-compiler-plugin/

You should specify the version in your project's plugin configuration:

<plugin>
   <groupId>org.apache.maven.plugins</groupId>
   <artifactId>maven-compiler-plugin</artifactId>
   <version>3.6.0</version>
</plugin>

You can download the appropriate sources etc. from the download page:

https://maven.apache.org/plugins/maven-compiler-plugin/download.cgi

Release Notes - Maven Compiler Plugin - Version 3.6.0

** Bug
     * [MCOMPILER-253] - testCompile (3.x) may not display error message  
when fork=true
     * [MCOMPILER-260] - Incorrect <compilerArgs> behavior when multiple  
number <arg>'s have the same value
     * [MCOMPILER-269] - Support modulepath (Java9/Jigsaw)
     * [MCOMPILER-279] - Passing multiple --add-exports args to the  
compilerArgs is not supported

** Improvement
     * [MCOMPILER-267] - Compiler plugin could have failOnWarning option
     * [MCOMPILER-273] - Upgrade maven-shared-utils to 3.1.0

** New Feature
     * [MCOMPILER-270] - Support release=8 on JDK 9 (with fallback on  
source=8 and target=8 on JDK 8)

Enjoy,

-The Apache Maven team
Loading...