[ANN] Apache Maven Scripting Plugin 3.0.0 Released

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[ANN] Apache Maven Scripting Plugin 3.0.0 Released

rfscholte
The Apache Maven team is pleased to announce the first release of the Apache Maven Scripting Plugin, version 3.0.0

The Maven Scripting Plugin wraps the Scripting API according to JSR223. Add the scripting engines as dependencies of this plugin on its use.

https://maven.apache.org/plugins/maven-scripting-plugin/

You should specify the version in your project's plugin configuration:

<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-scripting-plugin</artifactId>
<version>3.0.0</version>
</plugin>

Enjoy,

-The Apache Maven team
Reply | Threaded
Open this post in threaded view
|

Re: [ANN] Apache Maven Scripting Plugin 3.0.0 Released

Claude Brisson
Hi.

FYI, several links seem dead from the index page: usage, faq,
mailing-lists...

Also, the jsr223-script-engines only lists groovy, while there are
plenty others out there. Is it because the plugin only supports this
specific one?

On 21-03-02 08 h 29, Robert Scholte wrote:

> The Apache Maven team is pleased to announce the first release of the Apache Maven Scripting Plugin, version 3.0.0
>
> The Maven Scripting Plugin wraps the Scripting API according to JSR223. Add the scripting engines as dependencies of this plugin on its use.
>
> https://maven.apache.org/plugins/maven-scripting-plugin/
>
> You should specify the version in your project's plugin configuration:
>
> <plugin>
> <groupId>org.apache.maven.plugins</groupId>
> <artifactId>maven-scripting-plugin</artifactId>
> <version>3.0.0</version>
> </plugin>
>
> Enjoy,
>
> -The Apache Maven team
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]