[ANN] Apache Maven Javadoc Plugin 3.0.0-M1 Released

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[ANN] Apache Maven Javadoc Plugin 3.0.0-M1 Released

rfscholte
The Apache Maven team is pleased to announce the release of the Apache  
Maven Javadoc Plugin, version 3.0.0-M1

The Javadoc Plugin uses the Javadoc tool to generate javadocs for the  
specified project.

https://maven.apache.org/plugins/maven-javadoc-plugin/

You should specify the version in your project's plugin configuration:

<plugin>
   <groupId>org.apache.maven.plugins</groupId>
   <artifactId>maven-javadoc-plugin</artifactId>
   <version>3.0.0-M1</version>
</plugin>

You can download the appropriate sources etc. from the download page:

https://maven.apache.org/plugins/maven-javadoc-plugin/download.cgi

NOTE: this is a milestone release, because there are still some open  
issues which need to be fixed before the official 3.0.0, e.g. replace some  
deprecated parameters.
This release is mainly there to provide a Java9 compatible plugin  
(previous versions fail the build), even though not all Java 9 features  
are supported yet.

Release Notes - Maven Javadoc Plugin - Version 3.0.0-M1

** Bug
     * [MJAVADOC-467] - Aggregator reports should not require modules to be  
installed/deployed.
     * [MJAVADOC-472] - Conflicting dependency of plexus-utils are used
     * [MJAVADOC-476] - Remove link to non-existing Codehaus wiki
     * [MJAVADOC-477] - Use Javadoc instead of JavaDoc in the reporting  
output

** Dependency upgrade
     * [MJAVADOC-485] - Upgrade to commons-lang3
     * [MJAVADOC-486] - Upgrade to Doxia 1.7

** Improvement
     * [MJAVADOC-387] - Handle JDK8 -Xdoclint
     * [MJAVADOC-456] - Upgrade to Maven3 plugin

** Task
     * [MJAVADOC-458] - Upgrade of plexus-archiver to 3.4.
     * [MJAVADOC-459] - Upgrade of maven-archiver to 3.1.0.
     * [MJAVADOC-460] - Upgrade of maven-archiver to 3.1.1.
     * [MJAVADOC-461] - Upgrade of maven-plugins parent to 30.
     * [MJAVADOC-463] - Upgrade of commons-logging to 1.2.
     * [MJAVADOC-464] - Upgrade of log4j to 1.2.17.
     * [MJAVADOC-465] - Upgrade of commons-lang to 2.6.
     * [MJAVADOC-466] - Upgrade of httpclient to 4.5.2.
     * [MJAVADOC-474] - Deprecate parameter additionalparam
     * [MJAVADOC-491] - Require Java 7

Enjoy,

-The Apache Maven team

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...